I forgot my password for http://addons.mozilla.org/. Also I didn’t receive the link of password recovery on my email.

RESOLVED FIXED in 2014-09

Status

addons.mozilla.org Graveyard
Developer Pages
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: webschik, Assigned: clouserw)

Tracking

unspecified
2014-09

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8476223 [details]
Screen Shot 2014-08-19 at 9.23.43 AM.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140716183446

Steps to reproduce:

1. Go to https://addons.mozilla.org/en-US/firefox/users/login?to=%2Fen-US%2Ffirefox%2F
2. Click on the link "I forgot my password" (https://addons.mozilla.org/en-US/firefox/users/pwreset)
3.Enter email and click on the button "Send password reset link"
4. And I don't have this mail with link in my email.



Actual results:

I forgot my password for http://addons.mozilla.org/.  
Also I didn’t receive the link of password recovery on my email.


Expected results:

Password recovery link has to be sent to my email.
(Reporter)

Updated

3 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → 2014-09
I just tried and received the email, did you check in your spam?
Flags: needinfo?(webschik)
(Reporter)

Comment 2

3 years ago
I checked my Gmail (also Spam folder) - I don't receive the email.
Flags: needinfo?(webschik)
(Assignee)

Comment 3

3 years ago
What is the email you are trying this with?
(Reporter)

Comment 4

3 years ago
My email is webschik@gmail.com
(Assignee)

Comment 5

3 years ago
Did you get a password reset email now?
(Reporter)

Comment 6

3 years ago
I received the reset email, but I can't reset the password :(
First, I entered the new password, after that I saw:


"Oops! Not allowed.
You tried to do something that you weren't allowed to.
Try going back to the previous page, refreshing and then trying again"


I tried to repeat this action a few times and I had the same result.
(Reporter)

Comment 7

3 years ago
I used difficult passwords, like as D_3_c_6_a_8
(Assignee)

Comment 8

3 years ago
Please re-request a password reset at https://addons.mozilla.org/en-US/firefox/users/pwreset and then try to reset your password.
(Reporter)

Comment 9

3 years ago
I changed my password!!! And successfully logged in.
Thanks a lot, guys!
Thanks for your multiple attempts!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

3 years ago
Assignee: nobody → clouserw
Resolution: WORKSFORME → FIXED

Comment 11

3 years ago
I meet the same problem. I entered my email address guoyunhebrave@gmail.com to get password reset link. But I didn't receive any emails (also checked spam folder).

I have repeated many times.

Need help...
(Assignee)

Comment 12

3 years ago
I'm going to assume your trouble will be fixed with bug 1035375 so I'd suggest CCing yourself on that bug.

Comment 13

2 years ago
Hi, 

I have the same problem (no email received, junk folder checked too). I tried to contact Mozilla Addons by mail but no answers, so I cannot update my addons...
(Assignee)

Comment 14

2 years ago
(In reply to thunderseb from comment #13)
> Hi, 
> 
> I have the same problem (no email received, junk folder checked too). I
> tried to contact Mozilla Addons by mail but no answers, so I cannot update
> my addons...

It looks like you or your ISP reported the emails from Mozilla as abuse on Sep 22nd of this year so we don't send you emails anymore.  I can remove you from the blocklist if you can confirm that's what you would like.  Sending emails people don't want affects our ability to deliver any mail so we take it pretty seriously when someone clicks the link to report our mail as abusive (vs just unsubscribing or something).

Comment 15

2 years ago
(In reply to Wil Clouser [:clouserw] from comment #14)
> (In reply to thunderseb from comment #13)
> > Hi, 
> > 
> > I have the same problem (no email received, junk folder checked too). I
> > tried to contact Mozilla Addons by mail but no answers, so I cannot update
> > my addons...
> 
> It looks like you or your ISP reported the emails from Mozilla as abuse on
> Sep 22nd of this year so we don't send you emails anymore.  I can remove you
> from the blocklist if you can confirm that's what you would like.  Sending
> emails people don't want affects our ability to deliver any mail so we take
> it pretty seriously when someone clicks the link to report our mail as
> abusive (vs just unsubscribing or something).

Thanks for the answer. I'm surprised, I didn't reported the emails, and I'm still receiving emails from Mozilla Addons (notifications for comments and auto-check on addons...). But yes, you can remove my address from the blocklist :) . 

Thanks a lot
(Assignee)

Comment 16

2 years ago
Ok, you should have gotten an email asking you to click a link if you'd like to be off the blocklist.  There's a bunch of hoops because of the abuse report.  Once you click it, you should be good to go.

As far as other emails:  that's possible.  As we've evolved we've had to start using a service to send email, but older code where we send mail might not be going through the system yet.  Just a matter of time.

Cheers.

Comment 17

2 years ago
Thanks, it worked fine :)
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.