Can not install packaged apps on desktop as a reviewer

RESOLVED INVALID

Status

Marketplace
Reviewer Tools
RESOLVED INVALID
4 years ago
3 years ago

People

(Reporter: Aras Balali Moghaddam, Unassigned)

Tracking

Points:
---

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140716183446

Steps to reproduce:

I tried to do some app reviews yesterday:

* I went to marketplace reviewer tools
* select a packaged app that had desktop icon
* I hit the install button 
* I get a prompt in Firefox to install the app
* I hit install

Note: I have followed the instruction on https://wiki.mozilla.org/Marketplace/Reviewers/Apps/Guide/Setup#Android_and_Desktop for desktop using Firefox 31 and also nightly on both Mac and Linux machines.
Installing packaged apps on desktop had worked for me previously (last week)


Actual results:

The spinner keeps going for a while then install failed silently and the button text turns back to "install"

I tried with a few different packaged apps in the queue and I get the same results. For example, I tried installing the packaged app called "Flappy thirds" on my keon and it worked, but same app did not install on desktop.


Expected results:

Installing packaged app on desktop via reviewer tools should finish and button text should turn to "launch"
whats the error in the Browser console?
(Reporter)

Comment 2

3 years ago
I do not see any error in the console before or while trying to install the app. I only see a warning:

`Use of getUserData() or setUserData() is deprecated.  Use WeakMap or element.dataset instead.`

when opening the app view, but I dont think that is related. Am I supposed to do something to get debug information in browser console?
(Reporter)

Comment 3

3 years ago
I checked again just now and the `dom.mozApps.use_reviewer_certs` was not present. I am sure I had added that boolean property earlier and had it set to `true`, not sure how it had disappeared. I added the property again and now the install is working.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.