[Flame] Gallery app can be slow to decode and display image preview

RESOLVED FIXED

Status

Firefox OS
Gaia::Gallery
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: whsu, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.4 affected, b2g-v2.0 affected, b2g-v2.1 affected)

Details

(Reporter)

Description

4 years ago
* Description:
  This problem happened on v2.0 build.
  After entering preview mode, some thumbnails only shows half a thumbnail.
  @ Demo video.
    ~ http://youtu.be/-FT924myOg8
  @ Simple
    ~ Resolution: 1600*1200
    ~ Size: 348 KB
    ~ Image Type: image/jpeg

* Reproduction steps:
  1. Put many 1600*1200 pictures on the SIM card.
  2. Launch the gallery app
  3. Tap a picture
  4. Check the thumbnail

* Expected result:
  All thumbnails shows as normal.

* Actual result:
  Some thumbnails only shows half a thumbnail

* Reproduction build:
 - Gaia      a36a504f35bd9d1c20726624abe6433ce5dbfb54
 - Gecko     https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/4f9ee0d8dee8
 - BuildID   20140820160203
 - Version   32.0



Thanks!
(Reporter)

Comment 1

4 years ago
[Blocking Requested - why for this release]:

Not a good user experience.
blocking-b2g: --- → 2.0?
QA Wanted for branch checks.
Keywords: qawanted
This bug repro's on: Flame 2.1, Flame 2.0, Flame 1.4, Open C 2.1

Actual Results: Having 1600x1200 size photos on the phone and checking gallery, can result in images showing up as slivers of images before the fully load.

Repro Rate: 5/5

Environmental Variables:
Device: Flame Master
BuildID: 20140821060216
Gaia: c8e93dadeaec6a2617b4db8b7d65ba14aa8db378
Gecko: c14e5feadc61
Version: 34.0a1 (Master) 
Firmware Version: v123
------------------------------------------------
Environmental Variables:
Device: Flame 2.0
BuildID: 20140820203614
Gaia: 60cedd4aa6ba408174bcd20a7bf774e73f927674
Gecko: 45eca5871dd0
Version: 32.0 (2.0) 
Firmware Version: v123
------------------------------------------------
Environmental Variables:
Device: Flame 1.4
BuildID: 20140818062816
Gaia: 21bec64497dc06a7f12071d573570ba8fea598ae
Gecko: 07d78d0f9bef
Version: 30.0 (1.4) 
Firmware Version: v123
------------------------------------------------
Environmental Variables:
Device: Open_C Master
BuildID: 20140821060216
Gaia: c8e93dadeaec6a2617b4db8b7d65ba14aa8db378
Gecko: c14e5feadc61
Version: 34.0a1 (Master) 
Firmware Version: P821A10V1.0.0B06_LOG_DL
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v1.4: --- → affected
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch
not a regression
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Editing the title of this bug to better reflect what it is about:

1) This has nothing to do with thumbnails. It is about the preview image that you see after you tap on the thumbail.

2) the old bug title implied that the previews were never displayed correctly, when in fact it is just that they are slow to display.

This issue only occurs for images that do not have a suitably large EXIF preview image. On most hardware, photos from the camera do have a big enough EXIF preview, and those display quickly.  The sample image we use for testing (the one shown in the video) is kind of unfair to the gallery app because it does not have an EXIF preview.

In 1.3 and before, for images without EXIF previews, the gallery app would create its own preview image and store it on the sdcard for images like these.  That made scanning for new photos slower but was necessary to prevent excessive memory use and OOMs when quickly swiping between photos.

In 1.4 and later, we use the new #-moz-samplesize media fragment to decode the original image while also downsampling it. This saves memory so we don't have to create special separate preview images for those photos. Scanning is faster. But, as this bug points out, gallery is slower to display the image.

Gecko seems to do this display half the image and then display the second half thing. There have been a number of bugs filed about it, but I don't know if there is anything we can do about it. The issue is simply that gecko can't decode the image as quickly as we like.  I think this is just a CPU speed issue and there isn't much we can do unless we want to reconsider the scanning time tradeoff and go back to pre-computing previews for images like these.

If gecko provided an "ondecoded" event handler on img elements that would be called after the onload handler, we could use that to prevent the jarring visual of having only half the image displayed. But unless we want to pursue that option, I'd call this a WONTFIX

Bottom line: most users who mostly look at photos from the phone's camera will not see this behavior and we should not block on it.
Summary: [Flame][v2.0] Sometimes, the gallery app only shows half a thumbnail → [Flame][v2.0] Gallery app can be slow to decode and display image preview

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
(Reporter)

Comment 6

4 years ago
Thanks David!
I would like to set this bug as "---" since it is legacy problem and need a new mechanism to improve it.

Have a nice day!
blocking-b2g: 2.0? → ---
(Reporter)

Updated

4 years ago
Summary: [Flame][v2.0] Gallery app can be slow to decode and display image preview → [Flame] Gallery app can be slow to decode and display image preview
This one should already be fixed by Bug#1068986. Hi William, would you mind trying 2.1 to see if you can still reproduce this issue?

Thanks

Vance
Flags: needinfo?(whsu)
(Reporter)

Comment 8

3 years ago
Thanks David and Vance,

I cannot reproduce this bug after patch lands on v2.1.

* Build information:
 - Gaia      94dcc25f2e34a4900ea58310c26be52bcb089161
 - Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/baaa0c3ab8fd
 - BuildID   20141002000202
 - Version   34.0a2
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(whsu)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.