Closed Bug 1056614 Opened 5 years ago Closed 5 years ago

External translations not picked up for callscreen app

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1039854

People

(Reporter: pehrsons, Unassigned)

References

Details

First issue, v1.4 for bn-BD show up as completed in the dashboard since there hasn't been any commits to the repo since may, when its status was indeed completed.

Second issue, the missing translations need to be added.
I think callscreen has moved from dialer to its own app, so they might already exist and just have to be moved.
I saw in the log of a recent build that there were missing translations for firefox accounts in system app and ftu. These would need translations as well.
See dashboard at: https://l10n.mozilla.org/teams/bn-BD

Pike, flod, I am not sure if you are the goto-guys here, but would it be possible to have another run of gaia-v1_4 with bn-BD to make sure the dashboard and all related systems get up to date on the gaia state. This probably applies to more languages and versions as well.
Flags: needinfo?(l10n)
Flags: needinfo?(francesco.lodolo)
fx-accounts seems to be a 2.0 feature so that wouldn't matter. We however still need the callscreen ported. I can provide a patch that moves the callscreen translations out of dialer to the callscreen app, but what would review and landing procedures be like for an l10n patch?
Blocks: 990003
Callscreen's locales.ini actually points to dialer translations for en-US, ar, fr and zh-TW. This does not seem to be picked up for external localization repos however, as the "incoming" key does exist and is translated for bn-BD.

I'll move this to gaia land to see what can be done there.
Component: bn-BD / Bengali → Gaia::L10n
Product: Mozilla Localizations → Firefox OS
Moving to Dialer, 'cause it's a build issue, not a l10n library issue.

Also, clearing our needinfos.
Component: Gaia::L10n → Gaia::Dialer
Flags: needinfo?(l10n)
Flags: needinfo?(francesco.lodolo)
[Blocking Requested - why for this release]:
At least the "Incoming" and "Call Ended" strings in callscreen on v1.4 appear as non-localizable as external translations are not picked up for the callscreen app. Built-in locales in Gaia defer the localizations to communications/dialer, but this does not work for external locales.
blocking-b2g: --- → 1.4?
Flags: needinfo?(etienne)
Summary: [b2g][1.4][l10n][bn-BD] Translations needed for callscreen, fx-accounts → External translations not picked up for callscreen app
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(etienne) → needinfo?
Resolution: --- → DUPLICATE
Duplicate of bug: 1039854
Flags: needinfo?
blocking-b2g: 1.4? → ---
You need to log in before you can comment on or make changes to this bug.