Closed Bug 1056619 Opened 8 years ago Closed 7 years ago

Maximal scrolling speed is too low, making the browser feel slow

Categories

(Firefox for Android Graveyard :: Toolbar, defect)

All
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: gcp, Unassigned)

References

Details

http://www.reddit.com/r/firefox/comments/2dx2ro/latest_firefox_nightly_build_includes_chromecast/cjujkqi

I can more or less confirm the behavior observed: Chrome no longer limits its scrolling speed to the rendering speed (I'm sure it used to be different). It's maximal scrolling speed on a fling is way higher than ours, and as a result Firefox looks "sluggish" in comparison, even though we're actually rendering faster.

It's tricky to compare to other Android apps, but at least Gmail for example also makes stuff zip by *really* fast if you fling fast.
For what it's worth, the behavior I talk about also happens during the initial, single fling.
We don't limit the scrolling speed either on a single fling. It's just based on how fast your finger moves. The friction could be reduced though if that's the problem.

Another thing to consider is that often people test the scrolling speed on pages that have font-inflation. So the same page is actually longer in Firefox than it is on Chrome and so it just takes longer to get to the bottom. Make sure you have font inflation disabled when comparing scrolling speed.
It's almost impossible to compare because disabling our font inflation results in tiny, tiny text, while settings Chrome's scaling to 100% gives you much bigger text. If I set Chrome to 50% (the lowest), it's comparable, maybe, not sure. Need to make some graphical testing strip for the flingolympics :P

(still testing on planetkde.org)

When I try flinging as fast as possible, the scroll was smooth on Chrome and I nearly always ended up in the same place.

Doing the same in Firefox often lead to stutter and would end me up all over the page, sometimes about as far, but usually way short. (Nexus S) On my RAZRi, it was even worse and I ended up at blank page for several seconds.

I'm guessing the stutter I'm seeing is influencing the actual fling speed.
There should definitely be no stuttering. If you can reliably reproduce the stutter it might help to get a profile using the gecko profiler. And yeah until we fix the stutter there's probably not much point in looking at the friction parameters.
Now that bug 721421 and bug 1100315 are landed the situation here should be much better. If not by default, at least there's more prefs that people can play with to tune the behavior. Closing WFM unless we have specific feedback that needs addressing.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Depends on: 1125048
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.