Browser doesn't warn user about certificate error

RESOLVED WONTFIX

Status

defect
RESOLVED WONTFIX
5 years ago
Last year

People

(Reporter: kk1fff, Unassigned)

Tracking

unspecified
x86_64
Linux

Firefox Tracking Flags

(b2g-v2.1 affected, b2g-v2.2 affected)

Details

Attachments

(2 attachments)

STR:
1. Set phone time to 10 years ago, to produce SSL error.
2. Open an https site, like facebook, for example.

Expect:
Certificate error page or some warning message should be displayed to let user know that there is an SSL error.

Actual:
Nothing is shown, and the window remains blank.


I actually don't know what is the expected behavior. In old browser, we have the yellow error page. Is the error page supposed to be shown for this case?
I believe so, yes. Do you see ErrorPage.js being loaded in logcat?
Yes, I saw its log, along with log of certificate error. But the page is not shown on screen.
I have this issue on Flatfish device too, with version 2.2.0.0-prerelease (build id 20140904013801).
Any certificate error leads to a white blank page, instead of the yellow error page.
See Also: → 1083640
That is working properly in current 2.2 builds.

QA wanted to check on 2.1
Keywords: qawanted
Issue is reproducible on Flame 2.2 master and Flame 2.1.

Observed behavior on Flame 2.2: Facebook correctly shows a yellow warning page, but on other pages such as Twitter.com or Gmail.com, browser displays an error "Unable to connect" and user can only "Try again" or "Close". See attached screenshot. And tapping on Try Again doesn't help.

On Flame 2.1 it behaves the same except on twitter.com or gmail.com, instead of showing an Unable to Connect error it shows a blank page.

Tested on:
Device: Flame 2.2 Master
BuildID: 20141201032744
Gaia: 39214fb22c203e8849aaa1c27b773eeb73212921
Gecko: 08be3008650f
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 2.1
BuildID: 20141128073618
Gaia: ccb49abe412c978a4045f0c75abff534372716c4
Gecko: 18fb67530b22
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

---------

Browser2 isn't implemented on 2.0 but I checked it for reference anyway.

Issue does NOT occur on Flame 2.0. Browser correctly shows the yellow warning page when attempting to connect to facebook.com, twitter.com, and gmail.com.

Device: Flame 2.0
BuildID: 20141126072826
Gaia: 8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko: c756bd8bf3c3
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

----------

Not adding regression keyword since Browser2 only implemented on 2.1 onwards.
Posted file logcat on Flame 2.2
Adding a logcat.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.