Closed Bug 1056784 Opened 5 years ago Closed 4 years ago

Rendered SVG being cut-off in Firefox/Ubuntu

Categories

(Core :: SVG, defect)

31 Branch
x86_64
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1063486

People

(Reporter: harsh.manutdblu, Unassigned)

References

()

Details

(Keywords: reproducible)

Attachments

(4 files)

Attached image Erroneous Rendering
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140716183446

Steps to reproduce:

I created a SVG circle (or a bunch of partial arcs) arranged in a circular manner:

http://jsfiddle.net/RedDevil/gvbtr2Ly/

... and even animated it:

http://jsfiddle.net/RedDevil/u9u9rbbw/


Actual results:

The edges of the SVG image are cut-off at certain rotation angles. (Perhaps when the bounding-box is touching the image while it rotates...)


Expected results:

It should not have cut off
Attached image Reference Rendering
More info:

My Firefox: 31

Buildconfig:

b-linux64-hp-0033

Source
Built from https://hg.mozilla.org/releases/mozilla-release/rev/32dddf30405a

Build platform
target
x86_64-unknown-linux-gnu

Configure arguments
--enable-update-channel=release --enable-update-packaging --with-google-api-keyfile=/builds/gapi.data --enable-crashreporter --enable-release --enable-elf-hack --enable-stdcxx-compat --enable-warnings-as-errors --enable-official-branding



Graphics:

Adapter Description	Intel Open Source Technology Center -- Mesa DRI Intel(R) Ironlake Mobile
Device ID	Mesa DRI Intel(R) Ironlake Mobile
Driver Version	2.1 Mesa 10.1.3
GPU Accelerated Windows	0/1 Basic
Vendor ID	Intel Open Source Technology Center
WebGL Renderer	Intel Open Source Technology Center -- Mesa DRI Intel(R) Ironlake Mobile
windowLayerManagerRemote	false
AzureCanvasBackend	cairo
AzureContentBackend	cairo
AzureFallbackCanvasBackend	none
AzureSkiaAccelerated	0
Keywords: reproducible
I can reproduce using the second (animated) jsfiddle URL, on Linux Nightly.
34.0a1 (2014-08-20)
Status: UNCONFIRMED → NEW
Ever confirmed: true
I'd also like to add that in Firefox31/Windows7, the animated preview is rendering correctly, but the static one is still getting cut-off sadly. I'm not sure, but was thinking it could have been Cairo.... Does the windows version also use Cairo?
I believe on Windows, we use Direct2D instead of cairo, by default (if you haven't disabled hardware acceleration in preferences).

Given that you can reproduce a version of this there, seems like this is likely to be a Gecko bug.

Partially-reduced JSFiddle (with a fixed rotation amount, which triggers the problem reliably for me, regardless of viewport-size / zoomlevel): http://jsfiddle.net/vs17zcvm/
Further-reduced jsfiddle (just one <path>, with its numbers simplified a bit, and a stroke added):
  http://jsfiddle.net/vs17zcvm/3/

The right edge of the stroke is slightly clipped for me (more or less depending on viewport-size), and the green fill is much-more-severely clipped (which doesn't depend on viewport-size).
This is fixed on linux Nightly by the patch for bug 1063486, and works for me on Windows using ff38.

Kumar, are you still seeing the failure on Windows?  If not I'll close this one as a duplicate of 1063486.
Flags: needinfo?(harsh.manutdblu)
(In reply to Tom Klein from comment #7)
> This is fixed on linux Nightly by the patch for bug 1063486, and works for
> me on Windows using ff38.
> 
> Kumar, are you still seeing the failure on Windows?  If not I'll close this
> one as a duplicate of 1063486.

I'm still able to clearly observe intermittent chopped edges while animating in Firefox 39 on Ubuntu 14.04. I'm not able to use Windows currently. When I login to the Windows system, I'll report back with the findings.

Also, in :dholbert's reduced jsfiddle, the green filled area is chopped even in linux (the border around the green area is fine though!), again in FF-39 / Ubuntu-14.04
Flags: needinfo?(harsh.manutdblu)
(In reply to Tom Klein from comment #7)
> This is fixed on linux Nightly by the patch for bug 1063486

I can confirm this locally, BTW. I don't see any clipping in Nightly, and I used mozregression to find out when this changed. It gave me this range, which only includes bug 1063486:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=7a1fa81730e4&tochange=495a84cefc23

(Tested using first jsfiddle from comment 0 ( http://jsfiddle.net/RedDevil/gvbtr2Ly/ ) and my reduced jsfiddle ( http://jsfiddle.net/vs17zcvm/3/ ))

(In reply to Kumar Harsh from comment #8)
> I'm still able to clearly observe intermittent chopped edges while animating
> in Firefox 39 on Ubuntu 14.04 [...]  again in FF-39 / Ubuntu-14.04

That's expected -- the fix for this (bug 1063486) landed in the Firefox 41 timeframe. So Firefox 39 and 40 do not have the fix.

I'm duping this to bug 1063486, as suggested in comment 7, given that my local testing confirms Tom's claim in that comment.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1063486
(In reply to Tom Klein from comment #7)
> This is fixed on linux Nightly by the patch for bug 1063486, and works for
> me on Windows using ff38.

(Tom, just to clarify your mention of ff38 here: you're not suggesting bug 1063486's fix is in FF38, are you?

I think you were just responding to comment 4 which was indicating that a slightly-different version of this bug seemed to affect windows, and you're saying you can't reproduce that version of the bug [even without bug 1063486's patch].)
Flags: needinfo?(twointofive)
(If there is a remaining Windows issue with any of the testcases here, it'd be great to get a dedicated bug filed for that, since that'll probably be a bug in our Direct2D code, per comment 5 -- so, unrelated to the patch that fixed the larger linux issue here.

Kumar, if you could sanity-check whether you still see anything like this bug on Windows (per comment 4),
in Firefox 41 or newer*, and file a bug if so, that would be much appreciated!)

* e.g. Dev Edition: https://www.mozilla.org/en-US/firefox/channel/#developer
Flags: needinfo?(harsh.manutdblu)
(In reply to Daniel Holbert [:dholbert] from comment #11)
> (In reply to Tom Klein from comment #7)
> > This is fixed on linux Nightly by the patch for bug 1063486, and works for
> > me on Windows using ff38.
> 
> (Tom, just to clarify your mention of ff38 here: you're not suggesting bug
> 1063486's fix is in FF38, are you?
No.
> I think you were just responding to comment 4 which was indicating that a
> slightly-different version of this bug seemed to affect windows, and you're
> saying you can't reproduce that version of the bug [even without bug
> 1063486's patch].)
Right.
Thanks for wrapping this up! :)
Flags: needinfo?(twointofive)
(In reply to Daniel Holbert [:dholbert] from comment #12)
> Kumar, if you could sanity-check whether you still see anything like this
> bug on Windows (per comment 4),
> in Firefox 41 or newer*, and file a bug if so, that would be much
> appreciated!)
> 
> * e.g. Dev Edition: https://www.mozilla.org/en-US/firefox/channel/#developer

Works good in Dev Edition FF 41.0a2 ✌
Flags: needinfo?(harsh.manutdblu)
You need to log in before you can comment on or make changes to this bug.