embedded javascript changing listbox selectedIndex ignored

RESOLVED DUPLICATE of bug 104996

Status

()

Core
Layout: Form Controls
--
major
RESOLVED DUPLICATE of bug 104996
17 years ago
17 years ago

People

(Reporter: Craig Longman, Assigned: rods (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
in our application, we have many cases where we need to select a specific value
in a listbox while the page is loading.  for various reasons, we have to do this
via javascript, but there is a bug in the form manager in mozilla that breaks
everything.

basically, although the embedded js code appears to successfully set the
selectedIndex for a listbox ( an 'alert' shows the expected index ), when the
page is fully loaded, a completely different option is selected.

its almost as if the form manager is 'remembering' some values as the page
loads, then AFTER the page is all loaded, it runs around and modifies the
selected items again, thereby undoing any embedded selectedIndex changes.

see the provided URL for a pretty simple and succinct example.
jkeiser, is this really form manager or the stuff you're working on?

Comment 2

17 years ago
Not form manger.  Reassigning.
Assignee: morse → rods
Component: Form Manager → HTML Form Controls
QA Contact: tpreston → madhur

Comment 3

17 years ago
'Tis fixed in bug 34297.  Setting dependent.  (This may be a dup, but it relates
to setting selectedIndex instead of getting it, and I couldn't find such a bug
in my cursory search.)
Status: UNCONFIRMED → NEW
Depends on: 34297
Ever confirmed: true

Comment 4

17 years ago

*** This bug has been marked as a duplicate of 104996 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.