Search field in form loses focus; unable to return focus to text field.

VERIFIED DUPLICATE of bug 106489

Status

()

Core
Layout: Form Controls
VERIFIED DUPLICATE of bug 106489
16 years ago
16 years ago

People

(Reporter: corey, Assigned: kinmoz)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012
BuildID:    20011012

When user tries to enter text in the search field, cursor focus disappears from
text bod;  user is then unable to return focus to it.  User thus cannot use the
search function.

Reproducible: Always
Steps to Reproduce:
1. Load Client
2. go to URL: http://www.alibris.com/
3. Click in the "Search" field on the left-hand side of the page, to set focus.
4. Begin typing a search term


Actual Results:  After one keystroke, the focus disappears; user cannot enter
anything into the field, nor can s/he return focus to that field.  Keystroke
that user enters does not appear in text box.

Expected Results:  User should be able to enter a search term.

I first noticed this in 0.9.4;  It happens to me in the 0.9.5 build as well.

Comment 1

16 years ago
Created attachment 54252 [details]
Smallest possible html to reproduce this

Comment 2

16 years ago
This is caused by bad html.

Comment 3

16 years ago
confirming on windows 98 2001-10-17-18-0.9.4 branch build
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All

Comment 4

16 years ago
this is not for submition... moving to form controls
Component: Form Submission → HTML Form Controls

Comment 5

16 years ago
On my system (Windows 2000 running Build 2001101117), I am able to enter text 
into the search box, but clicking OK does nothing.  This appears to occur on 
every page; I cannot search for text within pages.

Comment 6

16 years ago
over to kin
Assignee: rods → kin
(Assignee)

Comment 7

16 years ago
This is a dup of 106489. The text you type is there, it's just not rendering.

*** This bug has been marked as a duplicate of 106489 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 8

16 years ago
verifying dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.