crash in mozalloc_abort(char const*) | NS_DebugBreak | mozilla::ipc::MessageChannel::Close()

RESOLVED DUPLICATE of bug 1048011

Status

()

Core
DOM: Content Processes
--
critical
RESOLVED DUPLICATE of bug 1048011
3 years ago
3 years ago

People

(Reporter: RobertM, Unassigned)

Tracking

({crash})

unspecified
All
Android
crash
Points:
---

Firefox Tracking Flags

(b2g-v2.1 affected)

Details

(Whiteboard: [2.1-flame-test-run-1], crash signature)

(Reporter)

Description

3 years ago
This bug was filed from the Socorro interface and is 
report bp-e565a387-1d7a-4443-afb4-f892b2140821.
=============================================================
Description:
After opening and closing video app, I removed the phone's SD card and then restarted. Upon start-up, there was a crash report.
   
prereq: Have an SD card with videos loaded on it in the phone.

Repro Steps:
1) Update a Flame device to BuildID: 20140820040203
2) Tap on 'Video' app to open it.
3) Close 'Video' app.
4) Remove the SD card from the device
5) Hold power button and tap 'Restart'
  
Actual:
Phone crashed when restarted.
  
Expected: 
Phone restarts without a crash.

Flame 2.1(319mb)
  
Environmental Variables:
Device: Flame 2.1 Master
BuildID: 20140820040203
Gaia: df39c463259d348396ef7f143c2c780eeb8f02d8
Gecko: ffdd1a398105
Version: 34.0a1 (2.1 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0
  
  
Repro frequency: (1/5, 20%)
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Adding qawanted to see if we can get a solid repro for this.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
After 25+ tries, I'm unable to reproduce this bug with the STR or any of the other things I've tried with and without pulling out the SD card. Leaving QAWanted for another tester to try.

Environmental Variables:
Device: Flame Master
Build ID: 20140821060216
Gaia: c8e93dadeaec6a2617b4db8b7d65ba14aa8db378
Gecko: c14e5feadc61
Version: 34.0a1 (Master)
Firmware Version: v122
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)

Updated

3 years ago
blocking-b2g: --- → backlog
Component: Gaia::Video → DOM: Content Processes
Product: Firefox OS → Core
This is some sort of race in startup code.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
(Reporter)

Updated

3 years ago
Whiteboard: [2.1-flame-test-run-1]
It's likely bug 1048011.
See Also: → bug 1048011
Kyle - do you have any feedback on comment 4? Can we dupe this issue to that bug?
Flags: needinfo?(khuey)
Yeah, let's do that.  If we see this again we can reopen.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(khuey)
Resolution: --- → DUPLICATE
Duplicate of bug: 1048011
blocking-b2g: backlog → ---
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.