Port bug 559505 to c-c (need to package xulstore)

VERIFIED FIXED in Thunderbird 34.0

Status

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Paenglab, Assigned: Paenglab)

Tracking

Trunk
Thunderbird 34.0
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird34 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

5 years ago
c-c needs the XULStore files in installer.
Assignee

Comment 1

5 years ago
This should fix the issues.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8476829 - Flags: review?(Pidgeot18)
Blocks: 1056649
Summary: Port bug 559505 to c-c → Port bug 559505 to c-c (need to package xulstore)
Assignee

Comment 2

5 years ago
Started a try-build: https://tbpl.mozilla.org/?tree=Thunderbird-Try&rev=f7a7c7e0f94d

Linux has a new bustage but Windows built. I used the installer version and it works.
Attachment #8476829 - Flags: review?(Pidgeot18) → review+
Assignee

Comment 3

5 years ago
http://hg.mozilla.org/comm-central/rev/aabbc0dc1a97
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 34.0

Updated

5 years ago
Blocks: 1057124
Richard, would you care to fix bug 1057124 too?
Blocks: 1056635
Product: Thunderbird → MailNews Core
Version: unspecified → Trunk
Duplicate of this bug: 1057648
Duplicate of this bug: 1057710

Comment 7

5 years ago
Tested with Build ID 20140821030202 -- same as before. Gona test tomorrow again.

As before: the last working Thunderbird is from Monday, 18th, Aug. 2014 (Build-ID: 20140818030204).

Comment 8

5 years ago
(In reply to Thomas Schweikle from comment #7)
> Tested with Build ID 20140821030202 -- same as before. Gona test tomorrow
> again.
> 
> As before: the last working Thunderbird is from Monday, 18th, Aug. 2014
> (Build-ID: 20140818030204).

It was suggested to me in Bug 1057648 that the tinderbox build 1408653497 would be the one to test.  It did not exists, so I installed 20140822143353 and it worked fine.

Comment 9

5 years ago
You are right. The xul-files are in installer now. But even with these in the installer:
Thunderbird ignores any personal setting for mail-tool-bar, disables menu if you personalize mail-tool-bar  settings, starts up full screen height, thus ignores last window size, opens up full calendar view even if you closed "tasks". Resets tabs to only one: main mail view, resets to default size for view pane. Ignores any selected sorting. My bug report https://bugzilla.mozilla.org/show_bug.cgi?id=1057710 was marked as duplicate of this one -- was definitely wrong ...
V.Fixed, per comment 8.

***

(In reply to Serge Gautherie (:sgautherie) from comment #4)
> Richard, would you care to fix bug 1057124 too?
Status: RESOLVED → VERIFIED
Flags: needinfo?(richard.marti)
Assignee

Comment 11

5 years ago
(In reply to Serge Gautherie (:sgautherie) from comment #10)
> (In reply to Serge Gautherie (:sgautherie) from comment #4)
> > Richard, would you care to fix bug 1057124 too?

Yep, a patch is attached with r?
Flags: needinfo?(richard.marti)
No longer depends on: 1058873
You need to log in before you can comment on or make changes to this bug.