[Status Bar] Update to Data Connection and Roaming

RESOLVED FIXED in Firefox OS v2.1

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: epang, Assigned: apastor)

Tracking

unspecified
2.1 S4 (12sep)
x86
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.1 fixed, b2g-v2.2 fixed)

Details

(Whiteboard: [systemsfe])

User Story

Visual Spec:
https://mozilla.box.com/s/e1uxmgwsi5qqtg7cgqdq

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Visual updates to the data connection alignment and decoupling of the roaming icon.

Roaming uses a new icon, will wait on exporting the icon until we know if we are using SVGs or will continue to use sprites.
(Reporter)

Comment 1

4 years ago
Added the visual spec to the user story.
User Story: (updated)
(Assignee)

Updated

4 years ago
Assignee: nobody → apastor
(Assignee)

Comment 2

4 years ago
Created attachment 8482686 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23628
Attachment #8482686 - Flags: ui-review?(epang)
Attachment #8482686 - Flags: review?(mhenretty)
Comment on attachment 8482686 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23628

Everything is looking great code-wise, but the icon needs to go to the left of the signal icon it relates to. Right now it is appended after.
Attachment #8482686 - Flags: review?(mhenretty)
(Assignee)

Comment 4

4 years ago
Created attachment 8483394 [details]
Screenshot of the implementation

But is floating right, isn't it. Attaching a screenshot of how that looks.
(Reporter)

Comment 5

4 years ago
Comment on attachment 8482686 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23628

Visually it looks good!  Thanks Alberto!
Attachment #8482686 - Flags: ui-review?(epang) → ui-review+
Duplicate of this bug: 949980
(Assignee)

Comment 7

4 years ago
master: https://github.com/mozilla-b2g/gaia/commit/da411e38e043a6dbc39d08407fa31f209eeee450
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → fixed
Created attachment 8484990 [details]
2014-09-05-16-50-39.png

Could the overlap of the H and signal icon that I see on current master on my Nexus S be related to this patch?
Flags: needinfo?(mhenretty)
Flags: needinfo?(apastor)
Depends on: 1063568
(Assignee)

Comment 9

4 years ago
Yeah, it looks it is. I'll work on https://bugzilla.mozilla.org/show_bug.cgi?id=1056969.

Thanks!
Flags: needinfo?(apastor)
Target Milestone: --- → 2.1 S4 (12sep)
Thanks Alex and Alberto!
Flags: needinfo?(mhenretty)
(Assignee)

Updated

4 years ago
Depends on: 1066557
(Assignee)

Updated

4 years ago
Depends on: 1068659
(Assignee)

Comment 12

4 years ago
Comment on attachment 8482686 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23628

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 996044
[User impact] if declined: Haida features are taking more space of the statusbar, so the less space we use for the icons, the better. If we don't take this patch (and the dependents) we'll miss important icons on the reduced version of the statusbar (when the rocketbar is active)
[Testing completed]: Added unit tests (on this one, and the bug found,1066557) 
[Risk to taking this patch] (and alternatives if risky): It has been for a while in master, and 1 bug (1066557) + some visual refinements (1063568, 1068659) were found, so is important to uplift the 3 dependent bugs just after this one (at least 1066557).

For more details regarding the importance of taking it, please talk to :robmac. Thanks!
[String changes made]:
Attachment #8482686 - Flags: approval-gaia-v2.1?(fabrice)
Attachment #8482686 - Flags: approval-gaia-v2.1?(fabrice) → approval-gaia-v2.1+
You need to log in before you can comment on or make changes to this bug.