Status

()

RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: mozilla.bugzilla.krt, Assigned: gordon)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
When using mozilla 0.9.5 (released build from the binaries - not a nightly build
or hand compiled from source) I get a an error on occasion that says that the
page requested cannot be found.  When I put my cursor on the URL line and hit
enter (similar to a reload?), it will then grab that page.  To verify that it
was not part of the infrastructure at my office (such as a transparent proxy
going nuts), I used Netscape under Linux and IE under win2k to perform the same
test.  As you can guess, the results were good for those browsers, as im filling
out this bug report now.

When requesting a "recently" visited page in Mozilla, this error happens -on
occasion-.  It is not easily reproduceable, but so far this is what I can do to
generate it:
1) visit a web site that uses tables.
2) visit a link on within a table that is local to the website
3) visit another link within that table to another local page
4) attempt to visit the link that was visited in step 2, and get the error
5) attempt to visit the link that was visited in step 2 -again-, and actually
   get the page.

Im using Linux kernel 2.4.6 on a SuSE 7.2 based IBM A22P laptop.

Thanks for making mozilla my favorite browser!

Comment 1

17 years ago
I have had the same (or very similar) problem using build 2002011803 (and other
recent nightly builds) on Win 2K.   After heavy surfing, a bookmark will
'occasionally' fail to work:  when I select the bookmark, the error message 'The
file / cannot be found.  Please check the location and try again.' is displayed.
 When this error occurs, I press Control + Reload (to reload the current page);
invariably, I am then able to select the same bookmark and navigate successfully
to the requested site.

Comment 2

17 years ago
This looks like a potential networking issue, rather than cache. 

Reporter, could you try to reproduce the problem after setting memory cache to 0
and disk cache to 0? 

Comment 3

17 years ago
Created attachment 69979 [details]
Selected bookmark to navigate to Dell site

Comment 4

17 years ago
Created attachment 69980 [details]
This is the error message that Mozilla displayted

After the error shown in the attachment was displayed, I cleared the cache
(both disk and memory).   After I cleared the cache, I selected the exact same
bookmark and was able to navigate successfully to the Dell site (no Mozilla
errors).   Wouldn't this suggest that the problem is in the cache?

Comment 5

17 years ago
I'm seeing this bug too, in build 2002021513 on Linux but also over the last
month or so.

I quite often leave a Mozilla window open for most of the day on my company's
intranet, and if I've left it alone for a couple of hours and then click Back, I
get the same "The file / could not be found" error. Also the stylesheet (which
is in an external .css file) often fails to load. I also have
http://www.mozilla.org/ as my startup page, and from time to time I see this
error on startup as it tries to load the page.

Further to previous comments, if I clear the cache the problem is solved. I have
been browsing for the last few days with both Memory and Disk Cache set to 0,
and have not seen any recurrence of the problem at all.

Comment 6

17 years ago
Reporter, are you by any chance running more than one *instance* of mozilla at
the same time?

That would definetely cause that.

Comment 7

17 years ago
this is most likely a dupe of bug 105746

i'm not going to mark it as such since the reporter didn't say whether he was
running more than one instance of mozilla.

reopen if you're still seeing this and *not* running multiple instances of mozilla
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.