[KK][Gallery] Allowing USB storage when deleting a photo results in overlapping text

RESOLVED WONTFIX

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED WONTFIX
4 years ago
4 months ago

People

(Reporter: SMiko, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v1.4 unaffected, b2g-v2.0 affected, b2g-v2.1 affected)

Details

(Whiteboard: [2.0-exploratory-kk])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8476955 [details]
2014-08-22-03-24-45.png

Description:
Overlapping text is displayed when plugging the phone into a laptop with USB storage enabled while deleting a video or picture.

Repro Steps:
1) Install the 165 base
2) Update a Flame to 20140821030000
3) Open Settings and enable USB storage
4) Open Gallery, chose a picture or video
5) Select the trash can icon and plug the phone into a laptop.
6) Rotate the phone to landscape mode

Actual:
The strings "Memory card in use" and "Delete selected item" overlap

Expected:
Overlapping text is not displayed.

Flame 2.0(319mb)

Environmental Variables:
Device: Flame 2.0 (319)
Build ID: 20140821030000
Gaia: d889984833025f208cfd3f3c2c37c87940a529dc
Gecko: 6329352ca531b977979451e77e5862af485388b2
Version: 32.0 (2.0)
Firmware Version: 
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Notes:
1)This issue also occurs in the Video app.

Repro frequency: 100%


See attached: screenshot

Video clip:
(Reporter)

Comment 1

4 years ago
Video clip: http://youtu.be/xPzw6FYFLUs

This issue DOES repro on Flame 2.1(319mb/123 base) Flame 2.0(512mb/165 base), Flame 2.0(319mb/123 base),and Open C 2.0 (123 base)

Actual Result: The strings "Memory card in use" and "Delete selected item" overlap

Flame 2.1 (319mb/123 base)

Environmental Variables:
Device: Flame Master (319mb)
BuildID: 20140820040203193
Gaia: df39c463259d348396ef7f143c2c780eeb8f02d8
Gecko: ffdd1a398105
Version: 34.0a1 (Master) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Flame 2.0(512mb/165 base)

Environmental Variables:
Device: Flame 2.0 (512mb)
Build ID: 20140821030000
Gaia: d889984833025f208cfd3f3c2c37c87940a529dc
Gecko: 6329352ca531b977979451e77e5862af485388b2
Version: 32.0 (2.0)
Firmware Version: 
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Flame 2.0 (319mb/123 base)

Environmental Variables:
Device: Flame 2.0 (319mb)
BuildID: 20140820000201
Gaia: 88db39a0826086024631049d83ae6aa397f0918d
Gecko: 2092ac87eceb
Version: 32.0 (2.0) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Open C 2.0 (123 base)

Environmental Variables:
Device: Open_C 2.0
BuildID: 20140820000201
Gaia: 88db39a0826086024631049d83ae6aa397f0918d
Gecko: 2092ac87eceb
Version: 32.0 (2.0) 
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

This issue does NOT repro on Flame 1.4 (319mb/123 base)

Actual Result: The gallery closes and the homescreen is displayed when plugging the device into a laptop with USB storage enabled.

Flame 1.4 (319mb/123 base)

Environmental Variables:
Device: Flame 1.4 (319mb)
Build ID: 20140820003001
Gaia: 4f92950e6d96326785a249e8acb704da3647616b
Gecko: e1de5a959089
Version: 30.0 (1.4)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v1.4: --- → unaffected
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected
Flags: needinfo?(ktucker)
Keywords: regression
Whiteboard: [2.0-exploratory-kk]
This looks bad but the user can get out of the overlapping messages. I don't know how many users would be plugging in their phone into the computer with usb storage enabled when deleting a photo. Not nominating as a blocker.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Component: Gaia::Gallery → Gaia::System::Window Mgmt
Flags: needinfo?(ktucker)
(Reporter)

Comment 3

4 years ago
Unable to obtain logcat due to needing USB storage enabled to produce the error message.

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]

Comment 4

4 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.