[Edge Gesture] Edge Gesture swipe overlay does not show renamed bookmark names during swipe

RESOLVED DUPLICATE of bug 1023791

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED DUPLICATE of bug 1023791
4 years ago
4 years ago

People

(Reporter: SalvadorR, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected)

Details

(Whiteboard: [2.1-flame-test-run-1], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8477048 [details]
edge gesture log.txt

Description:
After user renames a bookmark in homescreen and user uses edge gesture to switch between app and the bookmark, the overlay from switching to apps and bookmark do not show the new renamed bookmark in the overlay

Repro Steps:
1) Update a Flame to 20140820040203
2) Add a bookmark to homescreen and rename it
3) Open the bookmark
4) Press the home button and open any app
5) Use edge gesture to switch to the bookmark
6) Observe the name of the bookmark when overlay appears after switching

Actual:
The name of the renamed bookmark remains unchanged during Edge Gesture swipe overlay.

Expected:
The name of the renamed bookmark appears correctly during Edge Gesture swipe overlay.

Environmental Variables:

Flame 2.1 (319 mb)

Environmental Variables:
Device: Flame Master (319mb)
BuildID: 20140820040203193
Gaia: df39c463259d348396ef7f143c2c780eeb8f02d8
Gecko: ffdd1a398105
Version: 34.0a1 (Master) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/14139/
See attached: Video, Logcat
http://youtu.be/zlx0VeRyWdw
(Reporter)

Comment 1

4 years ago
This issue DOES OCCUR on Flame 2.1 (512 mb), Flame 2.0(319mb), Open C 2.1, Open C 2.0 devices.

Actual:
The name of the renamed bookmark remains unchanged during Edge Gesture swipe overlay.

Flame 2.1

Device: Flame Master (512mb)
Build ID: 20140820040203
Gaia: df39c463259d348396ef7f143c2c780eeb8f02d8
Gecko: ffdd1a398105
Version: 34.0a1 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Flame 2.0 

Environmental Variables:
Device: Flame 2.0 (319mb)
BuildID: 20140820000201
Gaia: 88db39a0826086024631049d83ae6aa397f0918d
Gecko: 2092ac87eceb
Version: 32.0 (2.0) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Open C 2.1

Environmental Variables:
Device: Open_C Master
Build ID: 20140820040203
Gaia: df39c463259d348396ef7f143c2c780eeb8f02d8
Gecko: ffdd1a398105
Version: 34.0a1 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Open C 2.0

Environmental Variables:
Device: Open_C 2.0
BuildID: 20140820000201
Gaia: 88db39a0826086024631049d83ae6aa397f0918d
Gecko: 2092ac87eceb
Version: 32.0 (2.0) 
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
---------------------------------------------------------------------

This issue is not implemented on Flame 1.4 (319mb), Open C 1.4 devices

Environmental Variables:

Flame 1.4

Device: Flame 1.4 (319mb)
Build ID: 20140820003001
Gaia: 4f92950e6d96326785a249e8acb704da3647616b
Gecko: e1de5a959089
Version: 30.0 (1.4)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Open C 1.4

Environmental Variables:
Device: Open_C 1.4
Build ID: 20140820003001
Gaia: 4f92950e6d96326785a249e8acb704da3647616b
Gecko: e1de5a959089
Version: 30.0 (1.4)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Not a regression and seems minor so not nominating to block on this.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Component: Gaia::Browser → Gaia::System::Window Mgmt
Flags: needinfo?(ktucker)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1023791
You need to log in before you can comment on or make changes to this bug.