images from signature html file do not work anymore (involving relative image paths?)

UNCONFIRMED
Unassigned

Status

UNCONFIRMED
5 years ago
4 years ago

People

(Reporter: critical.acclaim2, Unassigned)

Tracking

31 Branch
x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140716183446

Steps to reproduce:

Created HTML file, as done many times in prior versions 
Imported images (from same directory as the mail info)
Signature file comes up when "new message" is requested, but no image files


Actual results:

No images - and does not show as a broken link


Expected results:

As in the prior version I was using (V24), THE IMAGES SHOULD HAVE COME INTO THE NEW MESSAGE IN THE TABLE BOX ...
(Reporter)

Updated

5 years ago
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression, regressionwindow-wanted
Summary: Signature file - image display → images from signature html file do not work anymore
For image src which is relative (at least that's what i tested).
But relative path didn't work earlier either, just retested 24.
Status: NEW → UNCONFIRMED
Ever confirmed: false
doug, can you sent a copy of your HTML signature file to my email address (remove private data as required but I'll treat it confidentially)
Flags: needinfo?(critical.acclaim2)
Summary: images from signature html file do not work anymore → images from signature html file do not work anymore (involving relative image paths?)
Duplicate of this bug: 1090178
(Reporter)

Updated

4 years ago
Flags: needinfo?(critical.acclaim2)
Whiteboard: I have initially reported this bug ... but have since "realized", once again, that i was making an error between relative and absoulte loactions. Sorry, all is well with my use of the signature file.
(Reporter)

Comment 5

4 years ago
PS:  wonderful software.  I keep convincing people to switch to it ...
Per reporter's comment in whiteboard (where isn't the right place for such), this is wfm:

> I have initially reported this bug ...  but have since "realized", once again, that i was making an
> error between relative and absoulte loactions.  Sorry, all is well with my use of the signature file.

However, per Magnus comment 1, this bug was confirmed for relative paths (and later unconfirmed bc it doesn't seem to be a regression from TB24 to TB31, so it might be an RFE).

Magnus, can you attach a sample signature HTML file with relative paths as used in your test when you confirmed this? I can't quite imagine how that would work and look like as part of an email message.
Flags: needinfo?(mkmelin+mozilla)
Whiteboard: I have initially reported this bug ... but have since "realized", once again, that i was making an error between relative and absoulte loactions. Sorry, all is well with my use of the signature file.
Severity: major → normal
Keywords: regression, regressionwindow-wanted
That would be any html file where you have e.g. 

 <img src="foo.jpg" /> 

and foo.jpg is in the same directory as the html file referring to it.
Flags: needinfo?(mkmelin+mozilla)
You need to log in before you can comment on or make changes to this bug.