error: Installed distribution Django 1.6.5 conflicts with requirement Django>=1.6.6,<1.7 when running create-test-environment

RESOLVED FIXED

Status

Developer Services
Mercurial: bundleclone
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: glandium, Assigned: glandium)

Tracking

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
This is not specific to bundleclone, but afaict, there is no global version-control-tools bugzilla component.

Running create-test-environment fails after a while with:
error: Installed distribution Django 1.6.5 conflicts with requirement Django>=1.6.6,<1.7
(Assignee)

Comment 1

4 years ago
Created attachment 8477151 [details] [diff] [review]
Bump Django test-requirement to 1.6.6

This seems to do the job.
Attachment #8477151 - Flags: review?(gps)
(Assignee)

Updated

4 years ago
Assignee: nobody → mh+mozilla
Status: NEW → ASSIGNED

Comment 2

4 years ago
Comment on attachment 8477151 [details] [diff] [review]
Bump Django test-requirement to 1.6.6

Review of attachment 8477151 [details] [diff] [review]:
-----------------------------------------------------------------

Looks like this crept in from new ReviewBoard/Djblets packages. We don't pin some those packages, so we're susceptible to version incompatibilities over time like this.
Attachment #8477151 - Flags: review?(gps) → review+
(Assignee)

Comment 3

4 years ago
https://hg.mozilla.org/hgcustom/version-control-tools/rev/5ec7535e0c23
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Product: Other Applications → Developer Services
You need to log in before you can comment on or make changes to this bug.