Unexpected autocomplete results

VERIFIED FIXED in mozilla0.9.6

Status

P1
normal
VERIFIED FIXED
18 years ago
11 years ago

People

(Reporter: scottputterman, Assigned: bugzilla)

Tracking

({regression})

Trunk
mozilla0.9.6
x86
Windows NT
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Using the 11/19 trunk build I'm getting what I believe to be poor autcomplete
results on NT.

If I have in my address books:

sddd sbbb <sddd@abc.com>
Gzzz s <ffff@abc.com>

When I type "sddd sb" into the addressing widget it completes to "Gzzz s".  I
would expect it to complete to "sddd sbbb" since it appears to me to be a closer
match.
(Reporter)

Comment 1

18 years ago
So, I don't have time to come up with fake results for this other case I saw.

I typed in "robinf" which exists as an email address in my collected AB and got
back Rob Jaworski which exists as a dislay name.  I almost missent the email
because of this.

Updated

18 years ago
QA Contact: sheelar → nbaca
(Reporter)

Updated

18 years ago
Keywords: nsbeta1

Comment 2

18 years ago
Here are some other problems I see. I don't know the pattern.

These are the addresses in my collected address book:
Lisa Chiang (display name)  lisa_s_chiang@domain.com  (I made this address up 
since I use this for personal stuff and don't want spam to this.)
Lisa Chiang (display name)  lisatest01@netscape.com
Lisa Chiang (display name)  mslc5@aol.com
(no display name)  lisa-staff@netscape.com

When I type:  lisa-s, 
into the addressing field, I do not get matched to lisa-staff. I get a match to 
lisa_s_chiang@domain.com.

I have other examples if you need them.
(Reporter)

Updated

18 years ago
Keywords: nsbeta1 → nsbeta1+
(Reporter)

Comment 3

18 years ago
*** Bug 107921 has been marked as a duplicate of this bug. ***

Comment 4

18 years ago
here is my comments from the dup'ed bug.
"If I try to autocomplete 'sures', one of the entry in autocomplete popup shows
'Sean Su <ssu@netscape.com>'. "
(Reporter)

Comment 5

18 years ago
I realize this isn't perf work, but I'd like to consider this one of those bugs
that makes it hard to use mail.  Autocomplete pretty much never does the right
thing for me anymore.  If there's some quick fix that can be implemented before
or during the 0.9.6 closure then it would be great if it can be fixed then.  If
not then please move into 0.9.7
Priority: -- → P1
Summary: Unexpected autcomplete results → Unexpected autocomplete results
Target Milestone: --- → mozilla0.9.6
(Assignee)

Comment 6

18 years ago
accepting
Status: NEW → ASSIGNED

Comment 7

18 years ago
this should be 097. 096 closes tonight! And this is not an 096 stopper IMHO.
(Reporter)

Comment 8

18 years ago
I can move it to 0.9.7, but do you know how many times I've almost sent to the
wrong email address!  I bet it autocompletes incorrectly more than 50% of the time.
(Assignee)

Comment 9

18 years ago
My guess is that the work Alecf did when converting nsCRT::Strncmp to Convert
cause this regression (see bug 100214)
Keywords: regression
(Assignee)

Comment 10

18 years ago
I should be able to fix it by tonight...

Comment 11

18 years ago
the problem is that we also match any entries that have short prefixes which
share the same first letters as what someone typed.

i.e. if I type "Fred" I will also match "F Jones" and "Fr Smith" 

talked with jean-francois on the phone, and explained how I broke it :) 
(Assignee)

Comment 12

18 years ago
Created attachment 56784 [details] [diff] [review]
proposed fix, v1
(Assignee)

Comment 13

18 years ago
Alec, can you review the patch? Thanks.
Whiteboard: have fix

Comment 14

18 years ago
Comment on attachment 56784 [details] [diff] [review]
proposed fix, v1

sr=alecf
Attachment #56784 - Flags: superreview+

Comment 15

18 years ago
Comment on attachment 56784 [details] [diff] [review]
proposed fix, v1

r=varada
Attachment #56784 - Flags: review+
(Assignee)

Comment 16

18 years ago
Fixed and checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
Whiteboard: have fix

Comment 17

18 years ago
Trunk build 2001-11-09: WinMe, Linux RH 7.1, Mac 9.1
Verified Fixed. I tried all scenarios that were mentioned.
Status: RESOLVED → VERIFIED

Comment 18

18 years ago
*** Bug 107808 has been marked as a duplicate of this bug. ***
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.