Can't type korean 중성(CHUNG SUNG) character.

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: sangpire, Assigned: sangpire)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

46 bytes, text/x-github-pull-request
timdream
: review+
Details | Review | Splinter Review
(Assignee)

Description

4 years ago
Can't type Korean "중성 자모(CHUNG SUNG JA MO)" characters.
When didn't finish input last character.

# Steps to Reproduce
1. Select a text input box.
2. Change to the Korean keyboard.
3. Type this order 'ㅇㅓㅠㅠ'

# Results

Expected: '어ㅠㅠ'
Actual: '어'
(Assignee)

Comment 1

4 years ago
Created attachment 8478736 [details] [review]
GitHub Pull Request.

I fixed it.
Review please. :)
Attachment #8478736 - Flags: review?(timdream)
Attachment #8478736 - Flags: review?(timdream) → review+
I can see the test passes so I merged the patch.

master: https://github.com/mozilla-b2g/gaia/commit/0b03deb4c4ab9745a3af866be8d200550b6ff182

You might want to bump the submodule commit here
https://github.com/timdream/gaia-keyboard-demo

so we can have some fun trying out your Korean IME here.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Also, it's better if the comment of the commit describes the fix, instead of the bug.
(Assignee)

Comment 4

4 years ago
Thank you for review, Tim

I needs a more explain.

Then, If I found a new bug, 
Is it don't require to issue bugzilla? and just pull request with 'fix xxx' title !?

or 

Use 'fix xxxx' at Pull request description instead of bugzilla links?

Because I learned that use the Bugzilla bug number and title of the bug from this web page: https://developer.mozilla.org/en-US/Firefox_OS/Developing_Gaia/Submitting_a_Gaia_patch
You need to log in before you can comment on or make changes to this bug.