Closed Bug 1057321 Opened 5 years ago Closed 2 years ago

[Call Log]Call log can not distinguish the SIM cards from/to same number

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect, P2)

defect

Tracking

(b2g-v2.1 affected, b2g-v2.2 affected, b2g-master affected)

RESOLVED WONTFIX
Tracking Status
b2g-v2.1 --- affected
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: sync-1, Assigned: cawang)

References

Details

FFOS V1.4
 DEFECT DESCRIPTION:
  Call log can not distinguish the SIM cards from/to same number.
 
  REPRODUCING PROCEDURES:
  1.Make calls(ex:incoming/outgoing/missed) with both SIM1 and SIM2 to the same number.
  2.Enter call log interface.
  3.Call log can not distinguish the SIM cards from/to same number.(KO)
 
  EXPECTED BEHAVIOUR:
  Call log can distinguish the SIM cards from/to same number.
  
  Reference mobile's behavior:
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
  100%
 
  For FT PR, Please list reference mobile's behavior:
Duplicate of this bug: 1096594
Duped bug 1096594 has more information for Flame v2.1 and v2.2 reproduction.
The screenshot in bug 1096594 (attachment 8520197 [details]) contains a detailed analysis of the issue. Do you have a way to improve this, Carrie?
Flags: needinfo?(cawang)
Hi, 


Yes, I think we miss the case of DSDS when designing the call info page. I'd like to improve this after the 2.2 work done.
Assignee: nobody → cawang
Flags: needinfo?(cawang)
Assign to myself so I'll come back later.
This issue is occuring on Flame 3.0

Call log can not distinguish the SIM cards from/to same number.

Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150522010227
Gaia: 1126d8bee559f7cde675df2fcc6c196da9cfeba1
Gecko: 3e737d30f842
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 41.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.