Closed Bug 1057461 Opened 5 years ago Closed 5 years ago

layers.effect.invert = true or layers.effect.grayscale = true causes screen to crop on landscape mode in browser

Categories

(Core :: Graphics, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla35
blocking-b2g 2.1+
Tracking Status
firefox33 --- wontfix
firefox34 --- fixed
firefox35 --- fixed
b2g-v2.1 --- fixed
b2g-v2.2 --- fixed

People

(Reporter: njpark, Assigned: jrmuizel)

References

Details

Attachments

(1 file)

Attached image 2014-08-22-11-55-44.png
STR: Invert the screen by setting layers.invert to True and restart gaia
Open browser, go to http://mozilla.org/firefoxos in portrait mode
After the screen is rendered, hold the phone in landscape mode

Actual:
Half of the screen is not used.  (see attached image)

This could be the result of Bug 1016539 implementation
[Blocking Requested - why for this release]:
New feature (Bug 1057461) breaks the browser during the orientation change
blocking-b2g: --- → 2.1?
This also happens when grayscale is enabled
Summary: layers.invert = true causes screen to crop on landscape mode in browser → layers.invert = true or layers.grayscale = true causes screen to crop on landscape mode in browser
Blocks: 1016539
blocking-b2g: 2.1? → 2.1+
Hopefully we don't need access to the orientation flag.
Assignee: nobody → jmuizelaar
Note that once bug 1055891 lands (currently on inbound), the preference names are layers.effects.invert and layers.effects.grayscale.
Blocks: 1055891
a nonzero value for layers.effect.contrast also causes this bug
No longer blocks: 1055891
Blocks: 1055891
Summary: layers.invert = true or layers.grayscale = true causes screen to crop on landscape mode in browser → layers.effect.invert = true or layers.effect.grayscale = true causes screen to crop on landscape mode in browser
Depends on: 1064479
Duplicate of this bug: 1063843
I expect all the code landings necessary to fix this to be in bug 1064479.
Ran automation test to verify Bug 1064479.  It looks good in master, I'll mark this bug verified once it lands in 2.1 after a quick check.
Actually, just found a *possibly related* issue Bug 1066664 with the automation test.  We should check whether they are two unrelated bugs.
Marking fixed by bug 1064479.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
Status: RESOLVED → VERIFIED
Bug 1064479 has been uplifted if you want to verify this on v2.1.
You need to log in before you can comment on or make changes to this bug.