To address is parsed as address book group rather than single address (!!)

RESOLVED DUPLICATE of bug 1008718

Status

--
critical
RESOLVED DUPLICATE of bug 1008718
4 years ago
4 years ago

People

(Reporter: rocketraman, Unassigned)

Tracking

({regression})

31 Branch
x86_64
Windows 7
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
When sending an email to an address like "Group1 <foo@foo.com>", the standard e-mail parsing rules should cause this e-mail to be sent to "foo@foo.com". However, if Group1 exists, the e-mail will be sent to the e-mails that are part of Group1 and not foo@foo.com.

To reproduce:

1. Use an empty profile
2. In the address book, create a group called "Group1" with one more more addresses inside it.
3. Compose a new email
4. In the "To" field, enter "Group1 <foo@foo.com>"
5. Hit Send

The e-mail was sent to all of the e-mail addresses in Group1 with no warning or prompt message.

The e-mail should have been sent to the address "foo@foo.com" using the standard address format.

This bug is very serious -- an e-mail can be sent unintentionally to an entire group of people (this actually happened, and it was not good).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Keywords: regression
Resolution: --- → DUPLICATE
Duplicate of bug: 1008718
You need to log in before you can comment on or make changes to this bug.