update Unicode character data to version 7.0

RESOLVED FIXED in mozilla34

Status

()

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: jfkthame, Assigned: jfkthame)

Tracking

unspecified
mozilla34
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

Unicode 7.0 is out (released 2014.06.16), so we should update our data.
Attachment #8477698 - Flags: review?(smontagu)
Assignee: nobody → jfkthame
Status: NEW → ASSIGNED
Oops, forgot to regenerate this as part of the preceding patch.
Attachment #8477703 - Flags: review?(smontagu)
Comment on attachment 8477698 [details] [diff] [review]
patch 1 - update table-generating tools

Review of attachment 8477698 [details] [diff] [review]:
-----------------------------------------------------------------

::: intl/unicharutil/tools/genUnicodePropertyData.pl
@@ +228,1 @@
>  );

The # XXX comment above can be removed now!
Attachment #8477698 - Flags: review?(smontagu) → review+
Attachment #8477699 - Flags: review?(smontagu) → review+
Comment on attachment 8477703 [details] [diff] [review]
patch 3 - regenerate transliterate.properties for unicode 7.0

Review of attachment 8477703 [details] [diff] [review]:
-----------------------------------------------------------------

r=me (but this file is about to be removed anyway in bug 1003731)
Attachment #8477703 - Flags: review?(smontagu) → review+
Duplicate of this bug: 1026417
(In reply to Simon Montagu :smontagu from comment #5)
> r=me (but this file is about to be removed anyway in bug 1003731)

So it is. OK, this is a transient update!

(In reply to Simon Montagu :smontagu from comment #6)
> *** Bug 1026417 has been marked as a duplicate of this bug. ***

Huh, wonder why I failed to find that when I was filing this one? Sorry!


Pushed to inbound:
https://hg.mozilla.org/integration/mozilla-inbound/rev/4aad525f0dac
https://hg.mozilla.org/integration/mozilla-inbound/rev/af609a8d8f27
https://hg.mozilla.org/integration/mozilla-inbound/rev/7f6c74462362
Target Milestone: --- → mozilla34
You need to log in before you can comment on or make changes to this bug.