Tree style tabs addon no longer nests control-click'd links properly

RESOLVED INVALID

Status

()

Firefox
Extension Compatibility
RESOLVED INVALID
4 years ago
3 years ago

People

(Reporter: johns, Unassigned)

Tracking

34 Branch
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
On nightly, tree style tabs no longer nests new tabs under their parent when control-clicking links. I bisected this down to:

> http://hg.mozilla.org/mozilla-central/rev/785c653b41c3
> Author: Mike Conley <mconley@mozilla.com>
> Date:   Wed Aug 20 11:23:43 2014 -0400
> 
>     Bug 1050447 - Skip focusing content if we're opening a new about:blank or about:newtab tab. r=dao, feedback=jimm.
>     
>     This fixes a change in order of focus events for e10s after bug 1009628 landed.
>     We were accidentally focusing the content after focusing the URL bar for new
>     tabs. We now skip focusing the content entirely when opening a new tab.

Bug 1050447

Interestingly, tree-style tabs was already displaying this broken behavior in e10s before this change, bug 1042680
(Reporter)

Comment 1

4 years ago
So the issue is TST is doing this:

> if ('openLinkIn' in window) {
>   eval('window.openLinkIn = '+
>        window.openLinkIn.toSource().replace('browser.loadOneTab(',
> 	                                    'TreeStyleTabService.onBeforeOpenLinkWithParams(params); $&')
>       );
> }

Which matches the line 'browser.loadOneTab(' and inserts a call to onBeforeOpenLinkWithParams. Bug 1050447 cleaned up this line to avoid an unnecessary let statement above that, causing the always-robust search-and-replace-browser.js-code method fail.

@mike, do you think you can revert this line to prevent breaking this, since it's a pretty trivial difference? Otherwise we'll need to reach out to the TST author to fix his pattern matching
Flags: needinfo?(mconley)
I'm going to see if the add-on author will accept my pull request[1].

https://github.com/piroor/treestyletab/pull/759
Flags: needinfo?(mconley)
(In reply to John Schoenick [:johns] from comment #1)
> @mike, do you think you can revert this line to prevent breaking this, since
> it's a pretty trivial difference?

We're not going to do that. This needs to be fixed in the add-on.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID

Comment 4

3 years ago
Firefox 37.0.1 seems to have re-introduced this problem.

Using the Tree Style Tab add-on, a Ctrl-Click on a tab has opened a new tab as a child of the one the Ctrl-Click was done on. With 37.0.1 installed, Ctrl-Click now creates the new tab at the root level at the bottom of the tab list.
You need to log in before you can comment on or make changes to this bug.