Add an "x" to escape out of the new Tracking Protection / Mixed Content Blocker doorhanger

RESOLVED FIXED in Firefox 34

Status

()

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: tanvi, Assigned: tanvi)

Tracking

34 Branch
Firefox 34
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Assignee

Description

5 years ago
Per Philipp in https://bugzilla.mozilla.org/show_bug.cgi?id=1041748#c6, we need to add an x at the top right corner of the Mixed Content Blocker / Tracking Protection doorhanger.  In the current Mixed Content Blocker doorhanger as well as other doorhangers, we have an x.  This is particularly important because we are removing the "Keep Blocking" action, and we don't want users to think that disabling protection is their only option.

Implementation wise, is there a standard way to do add back the x?

I would for this to land in the same Firefox version as the new doorhanger lands to keep existing Mixed Content Blocker functionality for users who have tracking protection turned off.  If not, perhaps we could uplift it to Aurora.
Assignee

Comment 1

5 years ago
Adding Phillip to see if he can get us a mockup.
@Phillip, do we need X's at all? Historically we have had some debate as to the necessity of the X close button on panels, as they are designed to close by clicking anywhere outside of them.

For example, we don't have an X to close the Firefox menu panel, nor an X to close the Downloads panel.

I would be in favor of removing the X from the rest of these doorhangers. It adds visual noise and may lead people to believe that the only way to close them is through using the X (which requires narrow mouse movements and higher focus than clicking anywhere outside of the panel).
Flags: needinfo?(philipp)
Philipp* (sorry for the misspelling)
Assignee

Comment 4

5 years ago
If we don't use an "x", I'd like to add back the "Keep Blocking" or "Not Now" option.  Users who don't know they can click outside the doorhanger or hit escape should have a visible way to exit the doorhanger besides selecting "disable protection".
I agree with jaws. Besides the hamburger and downloads panel, the bookmarks panel and larry don't have an x. I think users are being trained to click outside to close, and keeping an x on certain panels and not others will add confusion.
The download and hamburger panels are distinct UI from the permission-style panels. The former are user-triggered (to get info / perform an action), the latter are browser/content-triggered prompts that ask questions. [The Larry panel is more like the former, but isn't a great example because it historically predates everything.]

It's unfortunate that this panel straddles the two intents -- it's a bit about info, a bit about permission, and so it wanders from UI convention and purpose.

I'd tend to think that since it's most similar to a permission prompt (anchor icon and visual style), that's what it should default to: having both an [X] and Keep Blocking + Not Now actions.
tl;dr Let's use the x for now.

The situation is not ideal.

I agree with Jared that the most elegant solution would be for all doorhangers to work like the menu panel. The problem is that we don't know how much there is to Tanvis concerns about users thinking they *have* to change an option in order to get out of the doorhanger. While my gut tells me that this shouldn't be a problem, I can't tell for sure.

UX has started to do some more holistic streamlining of our various permissions UI and that is one of the questions we need to answer in the process.
As it stands today, using the x for that doorhanger is consistent with most other doorhangers that originate from that part of the UI. I'd rather not add a separate Keep Blocking etc. button here, since that would produce its own set of problems when e.g. Mixed content is blocked but Tracking is allowed.
Flags: needinfo?(philipp)
Assignee

Comment 8

5 years ago
Attachment #8479581 - Flags: review?(gijskruitbosch+bugs)

Updated

5 years ago
Attachment #8479581 - Flags: review?(gijskruitbosch+bugs) → review+
Assignee

Comment 9

5 years ago
Pushed: https://hg.mozilla.org/integration/mozilla-inbound/rev/234a992d68eb
Assignee: nobody → tanvi
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/234a992d68eb
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 34
QA Whiteboard: [good first verify]
You need to log in before you can comment on or make changes to this bug.