build fail of libvpx because of GREP_OPTION

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
10 months ago

People

(Reporter: leejongsoo, Unassigned)

Tracking

Trunk
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
When GREP_OPTION="--color=always" is setted, it fails to build 'media/libvpx'.
It fails to compile 'quantize_sse4.o' because of 'vp8_asm_enc_offset.asm'
'vp8_asm_enc_offset.asm' has offset define and is generated using grep and sed.
'--color=always' option effects this process by adding some control character for color. below is the part of wrong generated 'vp8_asm_enc_offset.asm'

> ...
> ^[[01;31m^[[Kvp8_block_round EQU^[[m^[[K 56
> ^[[01;31m^[[Kvp8_block_quant EQU^[[m^[[K 16
> ^[[01;31m^[[Kvp8_block_quant_fast EQU^[[m^[[K 24
> ...

this code is generated using below code.

media/libvpx/Makefile.in
> # We can extract the asm offsets directly from generated assembly using inline
> # asm. This is the preferred method. However we need to strip out CFLAGS that
> # cause LTO because then the resulting .S file is useless.
> 
> vpx_scale_asm_offsets.s: CFLAGS := -DINLINE_ASM
> 
> OFFSET_PATTERN := '^[a-zA-Z0-9_]* EQU'
> ...
> vp8_asm_enc_offsets.asm: vp8_asm_enc_offsets.s
>    grep $(OFFSET_PATTERN) $< | sed -e 's/[$$\#]//g' \
>        $(if $(VPX_AS_CONVERSION),| $(VPX_AS_CONVERSION)) > $@

To resolve this issue, it needs to unset GREP_OPTION or using '--color=auto' or '--color=never'.
It needs to override GREP_OPTION with default value in build setting. At least, it need to provide some guide about GREP_OPTION issue.
(Reporter)

Updated

4 years ago
Component: Build Config → Build Config
Product: Firefox → Core

Comment 1

3 years ago
This particular build step was removed from upstream libvpx and has since propagated to Firefox. This should not be an issue any longer.

Comment 2

2 years ago
Long gone
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED

Updated

10 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.