Closed Bug 1057797 Opened 6 years ago Closed 6 years ago

Download completion not registering in FF, refusing to be canceled

Categories

(Firefox :: Untriaged, defect)

32 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1057764

People

(Reporter: void2258, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0 (Beta/Release)
Build ID: 20140822024446

Steps to reproduce:

Download a file. 


Actual results:

File fully downloads, including clearing any part files and being complete on disk. However in FF the download becomes "unknown time remaining" and never finishes. Closing warns you about canceling downloads. Every time FF is restarted it restarts this download (Because the finished file registers as a duplicate). Files cannot be canceled or removed without deleting the Downloads.json in the profile directory and restarting. 


Expected results:

Downloads should finish, allow cancellation.
Added Information:

Problem persists in Safe mode, so not due to add-on interaction.

Files completely finish downloading; zips and other test files checked and 100% intact and functional.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1057764
You need to log in before you can comment on or make changes to this bug.