Clean up mozL10n API use in Email

RESOLVED FIXED

Status

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: karanluthra06, Assigned: karanluthra06, Mentored)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

46 bytes, text/x-github-pull-request
jrburke
: review+
zbraniecki
: feedback+
Details | Review
No description provided.
Blocks: 1020137
Assignee: nobody → karanluthra06
Mentor: gandalf
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attachment #8477960 - Flags: feedback?(gandalf)
Comment on attachment 8477960 [details] [review]
Pull request for an attempt at this bug

Cool! That's a great first patch! Congratulations :)

There are two areas which I believe we could tackle in email:
 - Toaster can take l10nId for it's Toaster.toast(opts.text) and assign l10nId instead of settings textContent
 - The whole api.useLocalizedStrings should operate on l10nId's, not strings as well.

From what I understand, you'd prefer to land this patch and work on the follow up for those two? Sounds good to me!

I picked James as your reviewer since his review queue is empty (yay!). James, if you find a moment, that's just a clean up patch :)
Attachment #8477960 - Flags: review?(jrburke)
Attachment #8477960 - Flags: feedback?(gandalf)
Attachment #8477960 - Flags: feedback+
(In reply to Zibi Braniecki [:gandalf] from comment #2)
>  - The whole api.useLocalizedStrings should operate on l10nId's, not strings
> as well.

Please see bug 855198 and bug 1037266 for this part.  (Bug 905869 is related but covers an expansion of folder names we localize.)
Comment on attachment 8477960 [details] [review]
Pull request for an attempt at this bug

r+ if a couple of small nits about removing the `navigator.`, mentioned in the pull request, are fixed. If those are fixed, feel free to ping me or comment again in this bug, and I can do the merge.
Attachment #8477960 - Flags: review?(jrburke) → review+
Sorry for the delay, I just updated the PR. 
https://github.com/mozilla-b2g/gaia/pull/23246

Started taking a look at Zibi's and Andrew's inputs as well.

Thanks!
Merged in master:
https://github.com/mozilla-b2g/gaia/commit/5dbbd4ee09de929d6c388d19f128c902ac7d108f

from pull request:
https://github.com/mozilla-b2g/gaia/pull/23246
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.