B2G mochitest-debug-15 PROCESS-CRASH | /tests/toolkit/devtools/apps/tests/test_webapps_actor.html | application crashed [@ mozilla::layers::ISurfaceAllocator::~ISurfaceAllocator] | Assertion failure: mUsedShmems.empty()

RESOLVED DUPLICATE of bug 1016538

Status

()

Core
Graphics: Layers
RESOLVED DUPLICATE of bug 1016538
3 years ago
3 years ago

People

(Reporter: dbaron, Unassigned)

Tracking

({assertion, crash, intermittent-failure})

Trunk
ARM
Gonk (Firefox OS)
assertion, crash, intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
There's a new intermittent orange which shows up as:

PROCESS-CRASH | /tests/toolkit/devtools/apps/tests/test_webapps_actor.html | application crashed [@ mozilla::layers::ISurfaceAllocator::~ISurfaceAllocator]

though I think it's really a shutdown crash that just happens to be attributed to the last test.

20:03:54     INFO -  CPU: arm
20:03:54     INFO -       0 CPUs
20:03:54     INFO -  Crash reason:  SIGSEGV
20:03:54     INFO -  Crash address: 0x0
20:03:54     INFO -  Thread 0 (crashed)
20:03:54     INFO -   0  libxul.so!mozilla::layers::ISurfaceAllocator::~ISurfaceAllocator [ISurfaceAllocator.cpp:184bbe9eacf4 : 53 + 0x4]
20:03:54     INFO -       r4 = 0x446856a0    r5 = 0x446856d8    r6 = 0x446856a0    r7 = 0x00000000
20:03:54     INFO -       r8 = 0x00000001    r9 = 0x00000000   r10 = 0x44160040    fp = 0x00000001
20:03:54     INFO -       sp = 0xbead9730    lr = 0x40e2017d    pc = 0x40e20180
20:03:54     INFO -      Found by: given as instruction pointer in context
20:03:54     INFO -   1  libxul.so!mozilla::layers::CompositableForwarder::~CompositableForwarder [CompositableForwarder.h : 45 + 0x5]
20:03:54     INFO -       r4 = 0x446856a0    r5 = 0x446856d8    r6 = 0x446856a0    r7 = 0x00000000
20:03:54     INFO -       r8 = 0x00000001    r9 = 0x00000000   r10 = 0x44160040    fp = 0x00000001
20:03:54     INFO -       sp = 0xbead9740    pc = 0x40e2b78b
20:03:54     INFO -      Found by: call frame info
20:03:54     INFO -   2  libxul.so!mozilla::layers::ShadowLayerForwarder::~ShadowLayerForwarder [ShadowLayers.cpp:184bbe9eacf4 : 184 + 0x5]
20:03:54     INFO -       r4 = 0x446856a0    r5 = 0x44685700    r6 = 0x446856a0    r7 = 0x00000000
20:03:54     INFO -       r8 = 0x00000001    r9 = 0x00000000   r10 = 0x44160040    fp = 0x00000001
20:03:54     INFO -       sp = 0xbead9750    pc = 0x40e2b7eb
20:03:54     INFO -      Found by: call frame info
20:03:54     INFO -   3  libxul.so!mozilla::layers::ShadowLayerForwarder::~ShadowLayerForwarder [ShadowLayers.cpp:184bbe9eacf4 : 184 + 0x3]
20:03:54     INFO -       r4 = 0x446856a0    r5 = 0x446856a4    r6 = 0x446856a0    r7 = 0x00000000
20:03:54     INFO -       r8 = 0x00000001    r9 = 0x00000000   r10 = 0x44160040    fp = 0x00000001
20:03:54     INFO -       sp = 0xbead9768    pc = 0x40e2b809
20:03:54     INFO -      Found by: call frame info
20:03:54     INFO -   4  libxul.so!mozilla::AtomicRefCountedWithFinalize<mozilla::layers::ISurfaceAllocator>::Release() [AtomicRefCountedWithFinalize.h : 65 + 0x9]
20:03:54     INFO -       r4 = 0x00000001    r5 = 0x446856a4    r6 = 0x446856a0    r7 = 0x00000000
20:03:54     INFO -       r8 = 0x00000001    r9 = 0x00000000   r10 = 0x44160040    fp = 0x00000001
20:03:54     INFO -       sp = 0xbead9770    pc = 0x40e059d1
20:03:54     INFO -      Found by: call frame info
20:03:54     INFO -   5  libxul.so!mozilla::layers::TextureChild::~TextureChild [RefPtr.h : 301 + 0x5]
20:03:54     INFO -       r4 = 0x44625a40    r5 = 0x00000000    r6 = 0x00000000    r7 = 0x00000000
20:03:54     INFO -       r8 = 0x00000001    r9 = 0x00000000   r10 = 0x44160040    fp = 0x00000001
20:03:54     INFO -       sp = 0xbead9798    pc = 0x40e18c13
20:03:54     INFO -      Found by: call frame info
etc.
(Reporter)

Comment 1

3 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=46613416&tree=Mozilla-Inbound
b2g_emulator_vm mozilla-inbound debug test mochitest-debug-15 on 2014-08-22 18:36:39 PDT for push 184bbe9eacf4

https://tbpl.mozilla.org/php/getParsedLog.php?id=46615314&tree=Mozilla-Inbound
b2g_emulator_vm mozilla-inbound debug test mochitest-debug-15 on 2014-08-22 19:33:26 PDT for push bf2bf138571c

https://tbpl.mozilla.org/php/getParsedLog.php?id=46623937&tree=Mozilla-Inbound
b2g_emulator_vm mozilla-inbound debug test mochitest-debug-15 on 2014-08-23 00:34:15 PDT for push e7236c73a81c

https://tbpl.mozilla.org/php/getParsedLog.php?id=46637165&tree=Mozilla-Inbound
b2g_emulator_vm mozilla-inbound debug test mochitest-debug-15 on 2014-08-23 12:27:50 PDT for push fb0fdf7c9a10

https://tbpl.mozilla.org/php/getParsedLog.php?id=46646036&tree=Mozilla-Inbound
b2g_emulator_vm mozilla-inbound debug test mochitest-debug-15 on 2014-08-23 18:10:27 PDT for push e6abbd1b9555
(Reporter)

Comment 2

3 years ago
Oh, and somewhat well-hidden in the log (or is it even in the log?  tbpl shows it, anyway) is the:

Assertion failure: mUsedShmems.empty(), at ../../../gecko/gfx/layers/ipc/ISurfaceAllocator.cpp:53
Summary: B2G mochitest-debug-15 PROCESS-CRASH | /tests/toolkit/devtools/apps/tests/test_webapps_actor.html | application crashed [@ mozilla::layers::ISurfaceAllocator::~ISurfaceAllocator] → B2G mochitest-debug-15 PROCESS-CRASH | /tests/toolkit/devtools/apps/tests/test_webapps_actor.html | application crashed [@ mozilla::layers::ISurfaceAllocator::~ISurfaceAllocator] | Assertion failure: mUsedShmems.empty()
(Reporter)

Updated

3 years ago
Keywords: assertion
(Reporter)

Comment 3

3 years ago
For bisection to find the start, see down arrow from:
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&jobname=b2g_emulator.*mochitest-debug-15&rev=bf2bf138571c
Comment hidden (Treeherder Robot)
(Reporter)

Comment 5

3 years ago
So far this is looking like a regression from bug 1052240, i.e., this push:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?changeset=2dd8e4e95c55
though I triggered a few *more* retriggers on the previous push.
Flags: needinfo?(jgilbert)
(Reporter)

Updated

3 years ago
Blocks: 1052240
Comment hidden (Treeherder Robot)
(In reply to David Baron [:dbaron] (UTC-7) (needinfo? for questions) (away/busy Aug 27-Sep 11) from comment #5)
> So far this is looking like a regression from bug 1052240, i.e., this push:
> https://hg.mozilla.org/integration/mozilla-inbound/
> pushloghtml?changeset=2dd8e4e95c55
> though I triggered a few *more* retriggers on the previous push.

I just added tests. Maybe :nical knows more about this assert?
Flags: needinfo?(jgilbert) → needinfo?(nical.bugzilla)
Comment hidden (Treeherder Robot)
This is a dup of bug 1016538.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(nical.bugzilla)
Resolution: --- → DUPLICATE
Duplicate of bug: 1016538
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
You need to log in before you can comment on or make changes to this bug.