tahoecentral.com - Center part of page has wrong background color

VERIFIED FIXED

Status

P4
normal
VERIFIED FIXED
17 years ago
4 years ago

People

(Reporter: travis_caldwell2000, Assigned: bc)

Tracking

Details

(Whiteboard: [XBROWSER-CSS], URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012
BuildID:    2001101201

Load the page, the center region of the page 
( Below the "Tahoe central member LOG ON" frame and to the
right of the "Search tahoe central" frame )
has a dark blue background except for a white square in the
upper left hand corner.

Load the page under netscape 4.77 and the background appears white.

I believe the white background is correct, since some of the text is
mostly illegeble with the blue background.


Reproducible: Always
Steps to Reproduce:
1. Load the URL under mozilla
2. load it under netscape
3. compare the results

Comment 1

17 years ago
I see this too, win98SE 2001101803

confirming, OS -> All

I'm not that knowledgable about HTML, but validator.w3.org had small furry
offspring when I fed it this site.

NB: doing "view source" on this page gives radically different javascript*
depending on what browser you're using.  I didn't spot any differences in the
bulk of the page source, but I wouldn't be surprised if Moz was being fed
different HTML to other browsers.

*The javascript has some very suspect browser sniffing going on :

var n = document.layers ? 1 : 0
var ie = document.all ? 1 : 0

I wouldn't be surprised if the server-side client sniffing is similarly dodgy.

The dark blue appears to be the background from the <body> tag.  At first
glance, there's a style which should be applied to make the whole caboodle
white.  I'll try to cook up a simplified test case.

I suspect that this is style, rather than layout.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All

Comment 2

17 years ago
Got it.  Test cases to follow, demonstrating what's going on.

The page has an HTML-style comment (i.e. <!-- ..... -->) inside its
<style></style> tags.  Moz doesn't like this one little bit.  Remove that
comment, and you ahve a white background.  And some dodgy browser sniffing, but
there you go.

Comment 3

17 years ago
Created attachment 54341 [details]
testcase, with comment in <style> tags, -> broken

Comment 4

17 years ago
Created attachment 54342 [details]
testcase, no comment -> fixed

Comment 5

17 years ago
OK, this is NOT layout.

From comments in the very-similar-sounding bug 105233, I suspect that HTML
comments are illegal inside style sheets, which makes this ->tech evangelism

Since I'm not 100% about that, cc'ing bzbarsky@mit.edu : Boris, can you confirm
that I'm not talking rubbish on this.
Assignee: attinasi → bclary
Component: Layout → English: US
Keywords: testcase
Product: Browser → Tech Evangelism
QA Contact: petersen → zach
Version: other → unspecified
Yup.  The only sort of HTML comment that's legal in a sheet is for inline sheets
(<style> element) and like this:

<style type="text/css">
<!--
/* style rules go here */
-->
</style>

This is allowed for compatibility with really old browsers who understand not
the <style> element.
Keywords: testcase
Hardware: PC → All
Whiteboard: [XBROWSER-CSS]
(Assignee)

Updated

17 years ago
Priority: -- → P4
Summary: Center part of page has wrong background color → tahoecentral.com - Center part of page has wrong background color

Comment 7

17 years ago
fixed
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 8

17 years ago
Verified
2002022703/WinXP
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.