[e10s] The help menu is blank

VERIFIED FIXED in Firefox 34

Status

()

VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: lth, Assigned: mconley)

Tracking

Trunk
Firefox 34
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
Nightly 20140824030210, Ubuntu 14.04.  e10s enabled by default.  Browser freshly restarted.

Click on the Menu icon in the top right corner, then on the Help menu item near the bottom right.  The help menu that comes up is completely blank.
(Reporter)

Comment 1

4 years ago
Bug is present also in build 20140825030205.
Nightly 34.0a1 (2014-08-26) - Windows 8.1 x64

I can confirm this too. I also have e10s enabled by default. Works fine in a non-e10s window.
tracking-e10s: --- → ?
Summary: The help menu is blank → [e10s] The help menu is blank
Duplicate of this bug: 1058839
(Assignee)

Updated

4 years ago
Assignee: nobody → mconley
Blocks: 997462
tracking-e10s: ? → +
(Assignee)

Updated

4 years ago
Blocks: 1051017
(Assignee)

Comment 4

4 years ago
Created attachment 8481687 [details] [diff] [review]
Fix Help menu in e10s windows. r=?

The help menu wasn't populating properly because gSafeBrowsing was attempting
to get the URI for the loaded page by getting content.document.documentURI.
Since bug 1051017 landed, content is unavailable for e10s windows. We use
the selectedBrowser's documentURI instead.
(Assignee)

Comment 5

4 years ago
Comment on attachment 8481687 [details] [diff] [review]
Fix Help menu in e10s windows. r=?

Switches us from using content.document.documentURI to gBrowser.selectedBrowser.documentURI.spec. Seems to work nicely, and doesn't require us to use CPOWs!
Attachment #8481687 - Flags: review?(wmccloskey)
Comment on attachment 8481687 [details] [diff] [review]
Fix Help menu in e10s windows. r=?

Review of attachment 8481687 [details] [diff] [review]:
-----------------------------------------------------------------

Cool, thanks!

::: browser/base/content/browser-safebrowsing.js
@@ +9,5 @@
>      // A phishing page will have a specific about:blocked content documentURI
> +    var isPhishingPage = gBrowser.selectedBrowser
> +                                 .documentURI
> +                                 .spec
> +                                 .startsWith("about:blocked?e=phishingBlocked");

This might be a little clearer as:
  let url = (...).spec;
  let isPhishingPage = url.startsWith(...);

Up to you though.
Attachment #8481687 - Flags: review?(wmccloskey) → review+
(Assignee)

Comment 7

4 years ago
Created attachment 8481717 [details] [diff] [review]
Fix Help menu in e10s windows (r+'d by billm)

The help menu wasn't populating properly because gSafeBrowsing was attempting
to get the URI for the loaded page by getting content.document.documentURI.
Since bug 1051017 landed, content is unavailable for e10s windows. We use
the selected browser's currentURI instead.
(Assignee)

Updated

4 years ago
Attachment #8481687 - Attachment is obsolete: true
(Assignee)

Comment 8

4 years ago
Comment on attachment 8481717 [details] [diff] [review]
Fix Help menu in e10s windows (r+'d by billm)

Went with this approach - r+'d by billm over IRC.
Attachment #8481717 - Attachment description: Fix Help menu in e10s windows → Fix Help menu in e10s windows (r+'d by billm)
Attachment #8481717 - Flags: review+
(Assignee)

Comment 9

4 years ago
remote:   https://hg.mozilla.org/integration/fx-team/rev/5b89084d3dd6
Status: NEW → ASSIGNED
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/5b89084d3dd6
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 34
Verified the bad behavior on an old build and the fix on Mac 10.8.5 with the 2014-09-14 build. 
I double checked this isn't happening on Aurora while I was at it. 
Looking good! Waving my pom poms for e10s! :D
Status: RESOLVED → VERIFIED

Updated

3 years ago
Depends on: 1246115

Updated

3 years ago
Flags: needinfo?(mconley)

Updated

3 years ago
Flags: needinfo?(mconley)
You need to log in before you can comment on or make changes to this bug.