IonMonkey: (ARM) Assertion failure when running jsapi-tests for arm-simulator

RESOLVED FIXED in Firefox 33

Status

()

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: rankov, Assigned: rankov)

Tracking

Trunk
mozilla35
ARM
Linux
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox33 fixed, firefox34 fixed, firefox35 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

5 years ago
Here is the message. 

testJitMoveEmitterCycles_autogen3
Assertion failure: cx->runtime()->currentThreadOwnsInterruptLock(), at /scratch/work/github-gecko/gecko-dev/js/src/jsapi-tests/../jit/IonLinker.h:87
Segmentation fault (core dumped)

Also I suspect that jsapi-test are not run on tbpl. I can't find them in the log. I've looked at SM(ARM)
fwiw the use of AutoFlushICache also looks wrong in testJitMoveEmitterCycles.cpp. The AutoFlushICache should be in a lexical context that ends just after newCodeForIonScript(), so that the simulator icache is flushed before executing the code, rather than at the end of the function as-is.
Assignee

Comment 2

5 years ago
First problem was that call to rt->getJitRuntime(cx) was removed by previous patch.
I also fixed the problem Doug found by adding linkAndAllocate()
I also had to change all uses of CHECK macro.
Attachment #8482721 - Flags: review?(mrosenberg)
Assignee

Updated

5 years ago
Blocks: 1061761
Summary: IonMonkey: (ARM) Assetrion failure when running jsapi-tests for arm-simulator → IonMonkey: (ARM) Assertion failure when running jsapi-tests for arm-simulator
Comment on attachment 8482721 [details] [diff] [review]
Fix-testJitMoveEmitterCycles-arm.patch

Review of attachment 8482721 [details] [diff] [review]:
-----------------------------------------------------------------

How did this ever work with the comparison reversed?  I'm at least 20% sure that I tested this before I committed it.
Attachment #8482721 - Flags: review?(mrosenberg) → review+
Assignee

Comment 5

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/8e746619502b
Assignee: nobody → branislav.rankov
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/8e746619502b
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
Duplicate of this bug: 1073072
Comment on attachment 8482721 [details] [diff] [review]
Fix-testJitMoveEmitterCycles-arm.patch

Approval Request Comment
[Feature/regressing bug #]: dunno
[User impact if declined]: we will be unable to run jsapi-tests on beta because failures will be masked by this test and we will accidentally introduce a critical bug resulting in the complete destruction of Firefox's reputation and the Web will turn away from open solutions and stagnate again, preventing the creation of better worldwide communication mechanisms that turn out to be critical once we discover the giant asteroid heading for Earth and we will be unable to coordinate our response effectively enough to prevent it from hitting us and destroying all life and knocking out a second moon that will turn out to be shaped rather like an unattractive peanut
[Describe test coverage new/current, TBPL]: N/A, this *is* a test. But I think the patch has been on m-c for a while.
[Risks and why]: None, this patch only modifies a test
[String/UUID change made/needed]: none
Attachment #8482721 - Flags: approval-mozilla-beta?
Attachment #8482721 - Flags: approval-mozilla-aurora?
Comment on attachment 8482721 [details] [diff] [review]
Fix-testJitMoveEmitterCycles-arm.patch

Test only, taking.
BTW: https://twitter.com/MozillaReleases/status/515393074235990016 ;)
Thanks for the fun.
Attachment #8482721 - Flags: approval-mozilla-beta?
Attachment #8482721 - Flags: approval-mozilla-beta+
Attachment #8482721 - Flags: approval-mozilla-aurora?
Attachment #8482721 - Flags: approval-mozilla-aurora+
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.