Triggers memory leak in X

RESOLVED INVALID

Status

RESOLVED INVALID
17 years ago
14 years ago

People

(Reporter: kim.sandstrom, Assigned: asa)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.5) Gecko/20011012
XFree86-4.0.3-5
Redhat 7.1 with Ximian Gnome 1.4 (newly updated)

1. open gtop to monitor X memory usage (make a note of usage)
2. open mozilla
3. open any web page
4. close mozilla
5. repeat steps 2-4 a few times
6. have a look a gtop to monitor X memory usage. (compare to previous value)

It seems that mozilla allocates some X resources that are nor freed when mozilla
exits. Could this be hidden "ownerless" mozilla X windows??? I get the same
thing using Galeon.

Comment 1

17 years ago
1. Does the Xserver's memory usage "grow" in each cycle ?
2. Is it possible that the Xserver simply loads some fonts ? 
3. Please do not use gtop/top to report/check_for memory usage. "top" is
horrible - for example it reports ~580MB memory "usage" for my UltraSPARC's Xsun
because it counts all mmap()'ed framebuffer device memory as "used" memory (real
memory usage is ~60MB with tons of fonts loaded).

Comment 2

17 years ago
afaik, this is expected X behaviour. When X allocates memory for a picture,
then allocates some more memory after that, it can't deallocate the memory
for the picture. So if you use any program like top etc. it'll seem like X is
eating more and more memory. What actually happens is when the picture isn't
used anymore it gets swapped to disk. Unless you have a tiny swap partition it
shouldn't be a problem. INVALID, imho.

Comment 3

17 years ago
Marking INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.