Closed Bug 1058317 Opened 6 years ago Closed 5 years ago

[Browser] When watching YouTube on fullscreen, the video toolbar menu does not display

Categories

(Firefox OS Graveyard :: Gaia::System::Browser Chrome, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S4 (12sep)
blocking-b2g 2.1+
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: psiphantong, Assigned: yifan)

References

()

Details

(Keywords: regression, Whiteboard: [2.1-flame-test-run-1])

Attachments

(2 files)

Attached file yf.txt
Description:
When watching YouTube on fullscreen, the video toolbar menu does not display when tapping on the video 

Repro Steps:
1) Update a Flame to 20140825040204
2) Navigate into Browser2
3) Navigate to www.youtube.com
4) Tap on any video to start watching
5) Tap on the fullscreen icon
6) Tap on the video to bring up video toolbar

Actual:
the video toolbar menu does not display 

Expected:
the video toolbar menu display 


Environmental Variables:
Device: Flame Master (319mb)
BuildID: 20140825040204
Gaia: e424c85eda87a40c0fa64d6a779c3fa368bf770b
Gecko: daa84204a11a
Version: 34.0a1 (Master) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Repro frequency: 3/3 - 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/9005/
See attached: video, logcat, https://www.youtube.com/watch?v=7j0_1FOH41Q
This issue also reproduces on the Flame 2.1 (512mb), Open C 2.1. The video toolbar menu does not display 

Flame 2.1

Environmental Variables:
Device: Flame Master (512mb)
BuildID: 20140825040204
Gaia: e424c85eda87a40c0fa64d6a779c3fa368bf770b
Gecko: daa84204a11a
Version: 34.0a1 (2.1 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Open C 2.1

Environmental Variables:
Device: Open_C Master
Build ID: 20140825040204
Gaia: e424c85eda87a40c0fa64d6a779c3fa368bf770b
Gecko: daa84204a11a
Version: 34.0a1 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


____________________________________________________________________________________________________________________________


This issue does not reproduce on the Flame 2.0 (319mb), Open C 2.0, Flame 1.4 (319mb), Open C 1.4 because the Browser2 does not exist

Flame 2.0

Environmental Variables:
Device: Flame 2.0 (319mb)
BuildID: 20140825000201
Gaia: 4c8b5ced1966079086d86dec3098ecf340881306
Gecko: b0545e46d08b
Version: 32.0 (2.0) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Open C 2.0

Environmental Variables:
Device: Open_C 2.0
Build ID: 20140825000201
Gaia: 4c8b5ced1966079086d86dec3098ecf340881306
Gecko: b0545e46d08b
Version: 32.0 (2.0)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Flame 1.4

Environmental Variables:
Device: Flame 1.4 (319mb)
BuildID: 20140825063013
Gaia: cf9d74da6653efeb43d9653e81c61aa00e693a67
Gecko: cdcb73d0febc
Version: 30.0 (1.4)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Open C 1.4

Environmental Variables:
Device: Open_C 1.4
BuildID: 20140825063013
Gaia: cf9d74da6653efeb43d9653e81c61aa00e693a67
Gecko: cdcb73d0febc
Version: 30.0 (1.4)
Firmware: P821A10v1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
[Blocking Requested - why for this release]:

This works as intended on the original browser. It only happens on browser2. Nominating this 2.1? since this would impact a large number of end users.
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Component: Gaia::Browser → Gaia::System::Browser Chrome
FWIW, this works fine when playing local content through the Video App.  The video controls are gone, despite being in portrait or landscape mode.    I can reproduce this also against 2.1 Flame JB image.
(In reply to Tony Chung [:tchung] from comment #3)
> FWIW, this works fine when playing local content through the Video App.  The
> video controls are gone, despite being in portrait or landscape mode.    I
> can reproduce this also against 2.1 Flame JB image.

Oops that was a confusing comment.  

For the reproducible scenario of no video controls, i was referring to using the Youtube app from marketplace (or any other video loaded page through the browser).   Video app does NOT reproduce.
This issue also occur on vimeo, try dailymotion but that seems to be a separate issue (https://bugzilla.mozilla.org/show_bug.cgi?id=1036173)
Duplicate of this bug: 1060537
Assignee: nobody → yliao
Attached file pull request
When allowing fullscreen, the brower iframe was blocked by div#screenshot-overlay. The show/hide methods toggles 'visible' class but the class is not applied in stylesheet. Added relative visibility styles to fix this.
Attachment #8482114 - Flags: review?(fabrice)
Attachment #8482114 - Flags: review?(fabrice) → review?(alive)
:/ This is a regression. There was |visibility: hidden;| long time before.
Attachment #8482114 - Flags: review?(alive) → review+
blocking-b2g: 2.1? → 2.1+
Merged into master
https://github.com/mozilla-b2g/gaia/pull/23547

TBPL
https://tbpl.mozilla.org/?rev=a23cba7c1f18618fabea8c87fcd1a23c87fe2982&tree=Gaia-Try
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Please request Gaia v2.1 approval on this when you get a chance.
Target Milestone: --- → 2.1 S4 (12sep)
Yes, will do once TBPL passes.
Comment on attachment 8482114 [details] [review]
pull request

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): touch is blocked when webpage is in fullscreen mode
[User impact] if declined: users couldn't leave or interact with the fullscreen webpage without pressing home
[Testing completed]: https://tbpl.mozilla.org/?rev=c94fef1541f79e4bbb8cf45dcdec652bd86e02a1&tree=Gaia-Try
[Risk to taking this patch] (and alternatives if risky): no
[String changes made]: no
Attachment #8482114 - Flags: approval-gaia-v2.1?(bbajaj)
Attachment #8482114 - Flags: approval-gaia-v2.1?(bbajaj) → approval-gaia-v2.1+
This issue is still reproducible on Flame 2.2 and 2.1:

Flame 2.2 KitKat Base (319mb)(Full Flash)
  
Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20141002093155
Gaia: 191d805f4911628d37a8a90a1e23a6013995138f
Gecko: 5d6ec4dddf14
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
  
Flame 2.1 KitKat Base (319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.1
BuildID: 20141002000202
Gaia: 94dcc25f2e34a4900ea58310c26be52bcb089161
Gecko: baaa0c3ab8fd
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

The video toolbar menu does not display on the fullscreen mode.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
This is being tracked in bug 1071235
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Depends on: 1081758
Bug: 1081758  has been written, since this bug has failed verification
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][failed-verification]
No longer depends on: 1081758
This issue does not occur anymore on Flame 2.2 and Flame 2.2.

Actual: Video control appears and fully functions on fullscreen.

Flame 2.2

Environmental Variables:
Device: Flame Master (319mb)(KitKat Base)(FullFlash)
Build ID: 20141024040202
Gaia: d893a9b971a0f3ee48e5a57dca516837d92cf52b
Gecko: a5ee2769eb27
Version: 36.0a1 (Master)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Flame 2.1 

Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141024001204
Gaia: 0f76e0baac733cca56d0140e954c5f446ebc061f
Gecko: 7d78ff7d25b6
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][failed-verification] → [QAnalyst-Triage+]
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.