Some PL_DHashTable clean-ups

RESOLVED FIXED in mozilla34

Status

()

Core
XPCOM
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: njn, Assigned: njn)

Tracking

unspecified
mozilla34
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

4 years ago
Just some clean-ups.
(Assignee)

Comment 1

4 years ago
Created attachment 8478752 [details] [diff] [review]
(part 1) - Used |mFoo| form for PLDHashTable's private members

This patch renames all the private PLDHashTable fields to the |mFoo| form. It
leaves the public ones alone in order to minimize churn.

The patch also fixes the build when PL_DHASHMETER is defined.
Attachment #8478752 - Flags: review?(roc)
(Assignee)

Updated

4 years ago
Assignee: nobody → n.nethercote
Status: NEW → ASSIGNED
(Assignee)

Comment 2

4 years ago
Created attachment 8478753 [details] [diff] [review]
(part 2) - Remove unneeded comments and always-ignored warnings about chaining

This patch removes the stuff about double-hashing:

- the big comment explaining why double-hashing is better than chaining;

- the warning that everyone ignores about cases when chaining would be better.

We don't have a chaining hash table in the tree, so all this stuff about when
you should use chaining is pretty irrelevant.
Attachment #8478753 - Flags: review?(roc)
(Assignee)

Updated

4 years ago
Blocks: 1057485
https://hg.mozilla.org/mozilla-central/rev/9ebed11d8a2b
https://hg.mozilla.org/mozilla-central/rev/52b9465cc90b
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla34
(Assignee)

Updated

3 years ago
Blocks: 1128407
(Assignee)

Updated

3 years ago
Duplicate of this bug: 571167
You need to log in before you can comment on or make changes to this bug.