Closed Bug 1058373 Opened 5 years ago Closed 5 years ago

[MAC only] Add 'Command + Shift+ ]/[' as more convenient/consistent shortcuts to switch between TB tabs

Categories

(Thunderbird :: Toolbars and Tabs, enhancement)

31 Branch
x86
macOS
enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 541198

People

(Reporter: duoyingji, Unassigned)

References

(Blocks 2 open bugs, )

Details

(Keywords: ux-consistency, Whiteboard: [good first bug])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_4) AppleWebKit/537.77.4 (KHTML, like Gecko) Version/7.0.5 Safari/537.77.4

Steps to reproduce:

can't use general shortcut ("cmd + shift + [" or "cmd + shift + ]") to switch between tabs under Mac OSX (tested on OSX 10.9)



Actual results:

nothing


Expected results:

go to next or previous tab, like Firefox, Safari, Chromium, Finder, Terminal and many other applications under OSX.

Currently TB has "cmd+tab" and "ctl+fn+up/down" to switch between tabs, but it's not convenient according to Mac's keyboard layout and not consistent with many other applications.
https://support.mozilla.org/en-US/kb/keyboard-shortcuts
Use "Customize this Article" on the left to switch to TB31 and OS X shortcuts

Next Tab
Control + Tab
Command + Option + →

What about Command + Option + Cursor right/left?
That looks much more convenient and more memorable than
Command + Shift + ]/[ 

Firefox 31, per official documentation:

https://support.mozilla.org/en-US/kb/keyboard-shortcuts-perform-firefox-tasks-quickly?redirectlocale=en-US&redirectslug=Keyboard+shortcuts#os=win&browser=null

Use "Customize this Article" on the left to switch to OS X shortcuts

Next Tab
control + tab
control + page down
command + option + →

Questions:

1) I don't see cmd + shift + ] among these, so does that really work in FF?
2) Can you please cite any ideally official documentation where "cmd + shift + ]/[" (aka cmd+}/{) etc. is listed as default shortcut for switching tabs in browser?
3) Does Ctrl+Page down/up work on TB for MAC? (I guess yes, you need  Ctrl+fn+up/down to get that, right?)
Hmmm, confused from seeing. command + option + →

where is "page up" / "page down" on the mac keyboard? It's probably fn+cursor keys, but which cursor keys now, up/down or left/right?

Which of these work in firefox to switch tabs?
command + option + →/<-
command + option + cursor up/down
Severity: normal → enhancement
Summary: No convenient/consistent shortcuts to switch between TB tabs → [MAC only] Add more convenient/consistent shortcuts to switch between TB tabs
(In reply to Thomas D. from comment #1)
> Created attachment 8479035 [details]
> Apple MAC OS keyboard layout US English
> 
> https://support.mozilla.org/en-US/kb/keyboard-shortcuts
> Use "Customize this Article" on the left to switch to TB31 and OS X shortcuts
> 
> Next Tab
> Control + Tab
> Command + Option + →
> 
> What about Command + Option + Cursor right/left?
> That looks much more convenient and more memorable than
> Command + Shift + ]/[ 
> 
> Firefox 31, per official documentation:
> 
> https://support.mozilla.org/en-US/kb/keyboard-shortcuts-perform-firefox-
> tasks-quickly?redirectlocale=en-
> US&redirectslug=Keyboard+shortcuts#os=win&browser=null
> 
> Use "Customize this Article" on the left to switch to OS X shortcuts
> 
> Next Tab
> control + tab
> control + page down
> command + option + →
> 
> Questions:
> 
> 1) I don't see cmd + shift + ] among these, so does that really work in FF?


Yes, it does. Many Mac applications use these pair shortcuts.

Please check the section of "Application and other OS X shortcuts  These keyboard shortcuts work in most apps." at http://support.apple.com/kb/HT1343, in which shortcuts of cmd+]/[ (even without shift) are widely used. 



> 2) Can you please cite any ideally official documentation where "cmd + shift
> + ]/[" (aka cmd+}/{) etc. is listed as default shortcut for switching tabs
> in browser?


a) Please check http://support.apple.com/kb/PH17148 for Safari 7 shortcuts on switching tabs.

b) (cmd + }/{) shortcuts also work on firefox/chromium browsers, but they're not listed in their official help manuals.



> 3) Does Ctrl+Page down/up work on TB for MAC? (I guess yes, you need 
> Ctrl+fn+up/down to get that, right?)


Yes, but they're not convenient and consistent with other applications used. The benefit of (cmd + }/{) is that users don't need to move their hands away from main part of keyboard during writing and reading email in TB, like we code under Terminal application.
(In reply to Thomas D. from comment #1)
> Created attachment 8479035 [details]
> Apple MAC OS keyboard layout US English
> 
> https://support.mozilla.org/en-US/kb/keyboard-shortcuts
> Use "Customize this Article" on the left to switch to TB31 and OS X shortcuts
> 
> Next Tab
> Control + Tab
> Command + Option + →
> 
> What about Command + Option + Cursor right/left?
> That looks much more convenient and more memorable than
> Command + Shift + ]/[ 

Sorry for 2nd reply.

yes, it's more memorable. But it's not convenient during reading and composing mails, we have to move hands to the bottom edge of keyboard to do switch. 


> 
> Firefox 31, per official documentation:
> 
> https://support.mozilla.org/en-US/kb/keyboard-shortcuts-perform-firefox-
> tasks-quickly?redirectlocale=en-
> US&redirectslug=Keyboard+shortcuts#os=win&browser=null
> 
> Use "Customize this Article" on the left to switch to OS X shortcuts
> 
> Next Tab
> control + tab
> control + page down
> command + option + →
> 
> Questions:
> 
> 1) I don't see cmd + shift + ] among these, so does that really work in FF?
> 2) Can you please cite any ideally official documentation where "cmd + shift
> + ]/[" (aka cmd+}/{) etc. is listed as default shortcut for switching tabs
> in browser?
> 3) Does Ctrl+Page down/up work on TB for MAC? (I guess yes, you need 
> Ctrl+fn+up/down to get that, right?)
(In reply to ijk from comment #3)
> > 1) I don't see cmd + shift + ] among these, so does that really work in FF?
> Yes, it does. Many Mac applications use these pair shortcuts.
> 
> Please check the section of "Application and other OS X shortcuts  These
> keyboard shortcuts work in most apps." at
> http://support.apple.com/kb/HT1343, in which shortcuts of cmd+]/[ (even
> without shift) are widely used. 

I checked, but cmd + shift + ]/[ is not listed there, only without shift which then has a different function. Please add links to other documentation or tips & tricks page, I saw some when googling.

> > 2) Can you please cite any ideally official documentation where "cmd + shift
> > + ]/[" (aka cmd+}/{) etc. is listed as default shortcut for switching tabs
> > in browser?
> 
> a) Please check http://support.apple.com/kb/PH17148 for Safari 7 shortcuts
> on switching tabs.

Yep, that's confirmed:
Bring the next tab to the front: Control-Tab or Shift-Command (⌘)-[
Bring the previous tab to the front: Control-Shift-Tab or Shift-Command (⌘)-]

Now that documentation looks the wrong way round to me (the brackets are pointing to the wrong direction):
next tab should use Shift+] aka }
previous tab should use Shift+[ aka {
Am I right?

> b) (cmd + }/{) shortcuts also work on firefox/chromium browsers, but they're
> not listed in their official help manuals.

Yeah, shortcuts missing from documentation are a common problem which I've met before ;)

> > 3) Does Ctrl+Page down/up work on TB for MAC? (I guess yes, you need 
> > Ctrl+fn+up/down to get that, right?)
> 
> Yes, but they're not convenient and consistent with other applications used.
> The benefit of (cmd + }/{) is that users don't need to move their hands away
> from main part of keyboard during writing and reading email in TB, like we
> code under Terminal application.

Now assuming your keyboard looks like attachment 8479035 [details], I'm really wondering how you want to use this shortcut without moving your hand away from main part of keyboard:

Touch typing base position: left small finger on A, left index finger on F
CMD - need to flip left thumb underneath the hand
Shift - need to stretch left small finger far down - that's near painful stretching acrobatics while the thumb is still folded underneath and other fingers remain on middle row... are you sure you're not moving away from the original touch typing position?
]/[ - right hand, yeah that works

But yeah, if it helps for MAC users to have cross-application ux-consistency (Safari, Firefox, Terminal, ...) with more convenience as you say, I'll trust you on that one and why not. I'm always in favor of keyboard comfort :)

So the next thing is to find a coder who can/will implement this, and then get official UI-review for the patch.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: ux-consistency
Summary: [MAC only] Add more convenient/consistent shortcuts to switch between TB tabs → [MAC only] Add 'Command + Shift+ ]/[' as more convenient/consistent shortcuts to switch between TB tabs
Whiteboard: [good first bug]
And Thunderbird being Thunderbird, there had to be an existing neglected bug for this...

Thanks ijk for making the call, please DO answer my remaining questions here, and feel free to comment with your user experience in favor of Bug 541198...
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 541198
(In reply to Thomas D. from comment #5)
> (In reply to ijk from comment #3)
> > > 1) I don't see cmd + shift + ] among these, so does that really work in FF?
> > Yes, it does. Many Mac applications use these pair shortcuts.
> > 
> > Please check the section of "Application and other OS X shortcuts  These
> > keyboard shortcuts work in most apps." at
> > http://support.apple.com/kb/HT1343, in which shortcuts of cmd+]/[ (even
> > without shift) are widely used. 
> 
> I checked, but cmd + shift + ]/[ is not listed there, only without shift
> which then has a different function. Please add links to other documentation
> or tips & tricks page, I saw some when googling.
> 
> > > 2) Can you please cite any ideally official documentation where "cmd + shift
> > > + ]/[" (aka cmd+}/{) etc. is listed as default shortcut for switching tabs
> > > in browser?
> > 
> > a) Please check http://support.apple.com/kb/PH17148 for Safari 7 shortcuts
> > on switching tabs.
> 
> Yep, that's confirmed:
> Bring the next tab to the front: Control-Tab or Shift-Command (⌘)-[
> Bring the previous tab to the front: Control-Shift-Tab or Shift-Command (⌘)-]
> 
> Now that documentation looks the wrong way round to me (the brackets are
> pointing to the wrong direction):
> next tab should use Shift+] aka }
> previous tab should use Shift+[ aka {
> Am I right?


Yes.


> 
> > b) (cmd + }/{) shortcuts also work on firefox/chromium browsers, but they're
> > not listed in their official help manuals.
> 
> Yeah, shortcuts missing from documentation are a common problem which I've
> met before ;)
> 
> > > 3) Does Ctrl+Page down/up work on TB for MAC? (I guess yes, you need 
> > > Ctrl+fn+up/down to get that, right?)
> > 
> > Yes, but they're not convenient and consistent with other applications used.
> > The benefit of (cmd + }/{) is that users don't need to move their hands away
> > from main part of keyboard during writing and reading email in TB, like we
> > code under Terminal application.
> 
> Now assuming your keyboard looks like attachment 8479035 [details], I'm
> really wondering how you want to use this shortcut without moving your hand
> away from main part of keyboard:
> 
> Touch typing base position: left small finger on A, left index finger on F
> CMD - need to flip left thumb underneath the hand
> Shift - need to stretch left small finger far down - that's near painful
> stretching acrobatics while the thumb is still folded underneath and other
> fingers remain on middle row... are you sure you're not moving away from the
> original touch typing position?
> ]/[ - right hand, yeah that works


Left 'Shift' is just close to 'A' actually:)


> 
> But yeah, if it helps for MAC users to have cross-application ux-consistency
> (Safari, Firefox, Terminal, ...) with more convenience as you say, I'll
> trust you on that one and why not. I'm always in favor of keyboard comfort :)
> 
> So the next thing is to find a coder who can/will implement this, and then
> get official UI-review for the patch.


Thanks.
(In reply to Thomas D. from comment #5)
> So the next thing is to find a coder who can/will implement this, and then
> get official UI-review for the patch.

Wearing my mac-user hat, I'm going to give this a preliminary ui-r+, based soley on the description.  ;)
(In reply to Blake Winton (:bwinton) from comment #8)
> (In reply to Thomas D. from comment #5)
> > So the next thing is to find a coder who can/will implement this, and then
> > get official UI-review for the patch.
> 
> Wearing my mac-user hat, I'm going to give this a preliminary ui-r+, based
> soley on the description.  ;)

Thanks Blake :) And in bug 541198 to which this was duped, you already wrote up an excellent patch attachment 543044 [details] [diff] [review] to fix this in toolkit's tabbox.xml which was sidelined for the wrong reasons, namely no reasons... I hope we can revive your patch there. :)

I'll remember the trick with the hat, should try that too wearing my windows-keyboard-user hat for well-known swiss-knife shortcuts like Alt+Enter for contact properties... ;)
You need to log in before you can comment on or make changes to this bug.