[NFC] Sender device still could show shrinking UI when screen off/lock receiver device which contains a SIM card with secure element

VERIFIED FIXED in 2.1 S4 (12sep)

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: ashiue, Assigned: dimi)

Tracking

unspecified
2.1 S4 (12sep)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Created attachment 8478787 [details]
nfc_sender.log

Device    Flame
Gaia      1934a2297ffc0d90424cd9cd3294c4a8c74a7333
Gecko     https://hg.mozilla.org/mozilla-central/rev/18901d4f3edd
BuildID   20140825160203
Version   34.0a1

*Prerequisite:
(1) 2 phones(Device A and B) enable NFC
(2) One phone(Device A) is inserted a SIM card with secure element

STR:
1. Device B open a website
2. Device A screen off/lock
3. Tap two phones together

Expect result:
No shrinking UI shows on Device B

Actual result:
Device B show shrinking UI
(Reporter)

Comment 1

4 years ago
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.1?
QA Whiteboard: [COM=NFC]
Hi Alison,
If user tries to share URL after shrinking UI pops up, does it send to Device A?
(Reporter)

Comment 3

4 years ago
No, Device A receive nothing.
(Assignee)

Updated

4 years ago
Assignee: nobody → dlee
(Assignee)

Comment 4

4 years ago
Just update some testing result :
1. Reproduce this issue by using android phone as devices B . Android device also detect it as a p2p device and show its "shrinking" UI. So the problem is not related to device B.

2. Issue only happened when card emulation mode is enabled

3. device B detect device A as an tag with NFC-DEP protocol, that's why it show "shrinking" UI.
(Assignee)

Comment 5

4 years ago
Created attachment 8479764 [details]
android_behavior.log

Tested by Ming, using an android device with CE mode enabled and screen-off. The log is captured when tap flame device to the android device and from the log we can see that android CE mode will act as a type4 tag (ISO-DEP protocol).
(Assignee)

Comment 6

4 years ago
Hi Francis, Wesley,
The root cause of this bug is when flame(card emulation mode) is discovered by another device(reader mode), the reader device will find flame use NFC-DEP protocol which is for peer-to-peer connection.
So the shrink UI will show up.

We will need T2M or NXP's help to check why flame has this behavior because as mentioned in Comment 5, android device did behave differently.
Flags: needinfo?(whuang)
Flags: needinfo?(frlee)
hi Youlong,

may you please contact NXP and see what's the reason that Flame uses NFC-DEP protocol? please refer to comment6.

hi Dimi,

please also provide the base image version which you used. do you use v123 or v165?
Flags: needinfo?(frlee) → needinfo?(youlong.jiang)
(Assignee)

Comment 8

4 years ago
(In reply to Francis Lee [:frlee] from comment #7)
> hi Youlong,
> 
> may you please contact NXP and see what's the reason that Flame uses NFC-DEP
> protocol? please refer to comment6.
> 
> hi Dimi,
> 
> please also provide the base image version which you used. do you use v123
> or v165?
Hi Francis,

The result is tested with our latest pvt build.
And I just tried v123 image with the same nfcd tested in latest build, it seems flame use correct protocol (NFC-DEP). I will check what's the different bettwen v123 build and mozilla's pvt build first.

Note.Card emulation is not working for v165 so I cannot test it.
Flags: needinfo?(youlong.jiang)
Flags: needinfo?(whuang)
(Assignee)

Comment 9

4 years ago
I found this issue is realted to the libnfc-brcm.conf config file, after applying the config file in v123 base image, this issue is fixed.
Dimi, thank you very much for the update.
(Assignee)

Comment 11

4 years ago
Created attachment 8480439 [details] [review]
pull request to mozilla-b2g/device-flame patch

This issue is fixed after updating nfc config file in v123
Attachment #8480439 - Flags: review?(mwu)

Comment 12

4 years ago
(In reply to Dimi Lee[:dimi][:dlee] from comment #9)
> I found this issue is realted to the libnfc-brcm.conf config file, after
> applying the config file in v123 base image, this issue is fixed.

hi dimi -

we'll check libnfc-brcm.conf between v123 and v165 and feedback asap.

Updated

4 years ago
Attachment #8480439 - Flags: review?(mwu) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
(Assignee)

Comment 13

4 years ago
remove checkin-needed first because doing more test to check update configure file
Keywords: checkin-needed
(Assignee)

Comment 14

4 years ago
NFC function verified
- tag reading success
- p2p sharing url/image success
- card emulation mode with EVT_TRANSACTION success
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/device-flame/commit/f686fa63e8766a4799cffab0b072c7b80194c4fc
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S4 (12sep)
(Reporter)

Comment 16

4 years ago
Verified on
Gaia      fbb297c39aab5f17b179533d2a9a6c5166b2c197
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/fb5e796da813
BuildID   20140902160204
Version   34.0a2
Status: RESOLVED → VERIFIED
Keywords: checkin-needed
blocking-b2g: 2.1? → ---
(Assignee)

Comment 17

4 years ago
Created attachment 8510975 [details] [review]
[KK] Pull request to mozilla-b2g/device-flame

This patch also need to merge to KK branch
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
You need to log in before you can comment on or make changes to this bug.