Use clearer language to describe the impact of disabling different content blocking

RESOLVED FIXED in Firefox 34

Status

()

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Unfocused, Unassigned)

Tracking

30 Branch
Firefox 34
Points:
---
Bug Flags:
firefox-backlog +
qe-verify -

Firefox Tracking Flags

(Not tracked)

Details

For mixed content blocking we say "Disable protection for now".
For tracking protection we say "Disable protection".

There is a difference - disabling content blocking is for the lifetime of that tab, while disabling tracking protection is until it's re-enabled again and affects all tabs.

Some people have found that the language used doesn't make that clear to them - the language difference is too subtle, which leads to either confusion or assuming they're the same. 

So maybe we can find some clearer language to use here.
Flags: firefox-backlog+
Flags: qe-verify?
(In reply to Blair McBride [:Unfocused] from comment #0)
> For tracking protection we say "Disable protection".

This was intended to be "Disable protection for this site". Is that clear enough?
Just chatted with phlsa on irc. His feedback was that 

"Disable protection for now" with mixed content is clear enough to indicate temporary disabling (see also https://bugzilla.mozilla.org/show_bug.cgi?id=1041748#c6)

"Disable protection for this site" for tracking protection is enough to indicated that the site is unblocked until the user re-enables it.
From https://bugzilla.mozilla.org/show_bug.cgi?id=1058348#c6 it looks like it is OK to close this bug since phlsa is indeed UX.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 34
Iteration: --- → 34.3
Flags: qe-verify? → qe-verify-
You need to log in before you can comment on or make changes to this bug.