Empty or no <title> or image does not update title in tabbed browsing

VERIFIED FIXED in mozilla1.0.1

Status

SeaMonkey
Tabbed Browser
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: WeirdAl, Assigned: neil@parkwaycc.co.uk)

Tracking

Trunk
mozilla1.0.1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.5+) Gecko/20011019
BuildID:    Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.5+) Gecko/20011019

The title element, when empty, does not cause an override of the browser's
titlebar within tabbed browsing, as it normally does in ordinary browsing.  

Reproducible: Always
Steps to Reproduce:
1.  Open a new tab.  It should go to about:blank.
2.  Change URL in tab to about: and load the page.
3.  Change URL in tab to about:blank and load the page.

Actual Results:  Title bar changed after second step.  Title bar did not change
after third step.

Expected Results:  Title bar should change after the second step, and again
after third step.
(Reporter)

Comment 1

17 years ago
Interesting... the tab itself shows the correct title.  The window does not...

Also, swapping between tabs resets the window title correctly.  

This is such a small thing -- easily noticeable, but minor imho.
Severity: normal → minor

Comment 2

17 years ago
see the same with 2001101808, redhat. os->all...

Comment 3

17 years ago
You also get similar behaviour if you open a new tab, enter a URL, e.g hp.com,
let it load, then change the URL to about:blank

As noted, the tab shows the correct title, and swapping tabs resets it.

Reproduced on Windows 2000, Redhat Linux 7.1(ish), build 2001102414

Comment 4

17 years ago
Happens with images too (view image), so I can't see their dimentions. Extremely
annoying during development.
Severity: minor → normal
OS: Windows 98 → All
Hardware: PC → All
Summary: Empty <title></title> does not update title in tabbed browsing → Empty or no <title> or image does not update title in tabbed browsing

Comment 5

17 years ago
*** Bug 106058 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0.1
spam: set your filter for "SeverusSnape" to avoid the influx of bugmail

changing QA contact of open tabbed browser bugs from blake to me. if this bug
requires a reassignment, however, feel free to change it!
QA Contact: blakeross → sairuh

Comment 7

17 years ago
*** Bug 113036 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
This has NOTHING to do with tabed browsing. In fact, it was broken before tabs
were even checked in. Trying XP Apps.

Easier, much mre visable test case is 'view image' in the image context menu.
Title should update eaither to null, or preferably, the filename or something
similarly useful.

I think NS4 used the complete URL? plain/text documents could use the filename
there as well, not only for showing on the window name, but for bookmarking, tab
title ("(Untitled)" is freaking annoying), under the tasks menu, etc.

Actually, bookmarks already seem to remake the title, under the tasks menu, it
still shows the incorrect (previous) title.
Assignee: hyatt → pchen
Status: ASSIGNED → NEW
Component: Tabbed Browser → XP Apps
(Assignee)

Comment 9

17 years ago
Created attachment 61945 [details] [diff] [review]
Propsed patch

This patch ensures that title changes always reach the window title bar.
(Assignee)

Comment 10

17 years ago
I think this is a tabbed browser bug so restoring component.
Assignee: pchen → hyatt
Component: XP Apps → Tabbed Browser
Keywords: patch, review
hyatt/jag, how does this patch look?

Comment 12

17 years ago
Comment on attachment 61945 [details] [diff] [review]
Propsed patch

r=jag.
Attachment #61945 - Flags: review+

Comment 13

17 years ago
sr=hyatt

Comment 14

17 years ago
Still occuring in build from 2002010703. Nothing to do with tabs. When a page
doesn't have a title it retains the title from the previous page and does not
update the window.

Comment 15

17 years ago
Bug 105319 just fixed one specific case there, for xml documents with no
<xhtml:title>. I just posted a note there pointing here and saying a higher
level fix might be in order so the window title reset isn't cloned in 10
differant places.
(Reporter)

Comment 16

17 years ago
*** Bug 110866 has been marked as a duplicate of this bug. ***

Comment 17

17 years ago
Reassign to Neil so he gets the credit.
Assignee: hyatt → neil

Comment 18

17 years ago
Fix checked in for Neil.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
verified fixed using 2002.01.29.1x comm verif bits on linux rh7.2, win2k and mac
10.1.2.
Status: RESOLVED → VERIFIED

Comment 20

17 years ago
*** Bug 108546 has been marked as a duplicate of this bug. ***
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.