Closed Bug 1058423 Opened 6 years ago Closed 2 years ago

Hangs up at loading Ohloh Code Search

Categories

(Core :: Disability Access APIs, defect, critical)

x86_64
Windows 8.1
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: masayuki, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: hang, perf)

When I access following page in Ohloh Code Search, Firefox hangs up and CPU spikes up after showing the page contents.
http://code.ohloh.net/file?fid=7UyJXxx8y6GGv1-VeJSJ0JP9jIs&cid=hOh6fvYhQFU&s=ITfMouseTrackerACP&fp=491344&mp&projSelected=true#L0

I can reproduce this bug on both Firefox 31 and Nightly. And also I can reproduce this with safe mode.

On Google Chrome, I cannot reproduce this.
Setting accessibility.force_disabled = 1 seems to fix the high CPU usage problem.
Component: Untriaged → Disability Access APIs
Thank you, Alice-san. I tested again. If I change the pref, I can load mxr (e.g., http://mxr.mozilla.org/mozilla-central/source/layout/base/nsPresShell.cpp) smoother.

So, something of a11y has serious performance issue on a lot of page.

Alexander Surkov, do you know something about this?
Flags: needinfo?(surkov.alexander)
Keywords: perf
When I load nsPresShell.cpp of mxr, the profiler said:
http://people.mozilla.org/~bgirard/cleopatra/#report=af9390cc747b20f8d53d8befbfb612330e991980

According to the result of profile, following methods spend almost half of the time:

mozilla::a11y::Accessible::InvalidateChildrenGroupInfo()
mozilla::a11y::EventQueue::CoalesceReorderEvents(mozilla::a11y::AccEvent *)
mozilla::a11y::EventQueue::CoalesceEvents()
bug 1041070 might help with it
Flags: needinfo?(surkov.alexander)
Depends on: 1041070
(In reply to alexander :surkov from comment #4)
> bug 1041070 might help with it

Yeah, I confirmed that the patch of bug 1041070 fixes this bug.
I tested at nsPresShell.cpp in mxr.

In the default settings, perhaps by the fix of bug 1041070, the time to hang up is much shorter than I've experienced before. However, I still need long time to render the page. If I disable a11y module with |accessibility.force_disabled = 1|, I don't see any hanging up.

surkov:

Do you think that remaining cost is necessary? Or can improve with some hack? (e.g., using interruptable handling like layout)
Flags: needinfo?(surkov.alexander)
I bet we have some perf a11y issues to fix. Can you share a link at perf report?
Flags: needinfo?(surkov.alexander)
Okay, I'll do that later.
It's odd. I cannot reproduce this with prof-build on my development machine...
http://people.mozilla.org/~bgirard/cleopatra/#report=7b5f1d61b58e90f4478f7ea9b5fede66de77ae3e

I'll investigate what happens more. And if it's not caused by a11y module, I'll file another bug.
Hi! Is this still a problem with current Firefox?
Flags: needinfo?(masayuki)
I cannot access the website, but I don't experience this bug on dxr nor searchfox anymore. marking this as WFM.
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(masayuki)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.