[flatfish] build break in gecko/mfbt/tests/TestMaybe.cpp:242

RESOLVED DUPLICATE of bug 1057840

Status

Firefox OS
General
RESOLVED DUPLICATE of bug 1057840
4 years ago
4 years ago

People

(Reporter: dliang, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8478864 [details]
build.log

There is build break in gecko/mfbt/tests/TestMaybe.cpp:242

../../../gecko/mfbt/tests/TestMaybe.cpp: In function 'bool TestBasicFeatures()':
../../../gecko/mfbt/tests/TestMaybe.cpp:242:65: error: template argument 2 is invalid

In the directory  /home/dannyliang/work/codes/b2g_flatfish_github/objdir-gecko/mfbt/tests
The following command failed to execute properly:
/usr/bin/ccache /home/dannyliang/work/codes/b2g_flatfish_github/prebuilts/gcc/linux-x86/arm/arm-linux-androideabi-4.6/bin/arm-linux-androideabi-g++ -o TestMaybe.o -c -I../../dist/system_wrappers -include /home/dannyliang/work/codes/b2g_flatfish_github/gecko/config/gcc_hidden_dso_handle.h -DIMPL_MFBT -DAB_CD=en-US -DNO_NSPR_10_SUPPORT -I/home/dannyliang/work/codes/b2g_flatfish_github/gecko/mfbt/tests -I. -I../../dist/include -I/home/dannyliang/work/codes/b2g_flatfish_github/objdir-gecko/dist/include/nspr -I/home/dannyliang/work/codes/b2g_flatfish_github/objdir-gecko/dist/include/nss -I../../dist/include/testing -fPIC -DANDROID -isystem /home/dannyliang/work/codes/b2g_flatfish_github/bionic/libc/arch-arm/include -isystem /home/dannyliang/work/codes/b2g_flatfish_github/bionic/libc/include/ -isystem /home/dannyliang/work/codes/b2g_flatfish_github/bionic/libc/kernel/common -isystem /home/dannyliang/work/codes/b2g_flatfish_github/bionic/libc/kernel/arch-arm -isystem /home/dannyliang/work/codes/b2g_flatfish_github/bionic/libm/include -I/home/dannyliang/work/codes/b2g_flatfish_github/system -I/home/dannyliang/work/codes/b2g_flatfish_github/system/core/include -isystem /home/dannyliang/work/codes/b2g_flatfish_github/bionic -I/home/dannyliang/work/codes/b2g_flatfish_github/hardware/libhardware/include -I/home/dannyliang/work/codes/b2g_flatfish_github/external/valgrind/fxos-include -I/home/dannyliang/work/codes/b2g_flatfish_github/frameworks/native/include -I/home/dannyliang/work/codes/b2g_flatfish_github/frameworks/av/include -I/home/dannyliang/work/codes/b2g_flatfish_github/frameworks/av/include/media -I/home/dannyliang/work/codes/b2g_flatfish_github/frameworks/av/include/camera -I/home/dannyliang/work/codes/b2g_flatfish_github/frameworks/native/include/media/openmax -I/home/dannyliang/work/codes/b2g_flatfish_github/frameworks/av/media/libstagefright/include -DMOZILLA_CLIENT -include ../../mozilla-config.h -MD -MP -MF .deps/TestMaybe.o.pp -DANDROID -isystem /home/dannyliang/work/codes/b2g_flatfish_github/bionic/libc/arch-arm/include -isystem /home/dannyliang/work/codes/b2g_flatfish_github/bionic/libc/include/ -isystem /home/dannyliang/work/codes/b2g_flatfish_github/bionic/libc/kernel/common -isystem /home/dannyliang/work/codes/b2g_flatfish_github/bionic/libc/kernel/arch-arm -isystem /home/dannyliang/work/codes/b2g_flatfish_github/bionic/libm/include -I/home/dannyliang/work/codes/b2g_flatfish_github/system -I/home/dannyliang/work/codes/b2g_flatfish_github/system/core/include -isystem /home/dannyliang/work/codes/b2g_flatfish_github/bionic -I/home/dannyliang/work/codes/b2g_flatfish_github/hardware/libhardware/include -I/home/dannyliang/work/codes/b2g_flatfish_github/external/valgrind/fxos-include -I/home/dannyliang/work/codes/b2g_flatfish_github/frameworks/native/include -I/home/dannyliang/work/codes/b2g_flatfish_github/frameworks/av/include -I/home/dannyliang/work/codes/b2g_flatfish_github/frameworks/av/include/media -I/home/dannyliang/work/codes/b2g_flatfish_github/frameworks/av/include/camera -I/home/dannyliang/work/codes/b2g_flatfish_github/frameworks/native/include/media/openmax -I/home/dannyliang/work/codes/b2g_flatfish_github/frameworks/av/media/libstagefright/include -Wall -Wpointer-arith -Woverloaded-virtual -Werror=return-type -Werror=int-to-pointer-cast -Werror=type-limits -Wempty-body -Wsign-compare -Wno-invalid-offsetof -mandroid -fno-short-enums -fno-exceptions -Wno-psabi -DMOZ_ENABLE_JS_DUMP -include /home/dannyliang/work/codes/b2g_flatfish_github/gonk-misc/Unicode.h -I/home/dannyliang/work/codes/b2g_flatfish_github/gecko/build/stlport/stlport -I/home/dannyliang/work/codes/b2g_flatfish_github/ndk/sources/cxx-stl/system/include -march=armv7-a -mthumb -mfpu=neon -mfloat-abi=softfp -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -std=gnu++0x -pipe -DNDEBUG -DTRIMMED -g -freorder-blocks -Os -fno-reorder-functions -funwind-tables /home/dannyliang/work/codes/b2g_flatfish_github/gecko/mfbt/tests/TestMaybe.cpp
make[6]: *** [TestMaybe.o] Error 1
make[6]: *** Waiting for unfinished jobs....
(Reporter)

Comment 1

4 years ago
SW version:
Gecko: 79bcafc2c6846a00ea93693570966b475c03bb60
Gaia: 7e2165cbc81d32188a2a7cf0f4bac6a61c7f42fc
(Reporter)

Updated

4 years ago
See Also: → bug 913586
(Reporter)

Comment 2

4 years ago
hi Seth, flatfish is contribution program and we don't put it on try-server. It's possible to have some build break due to it's JB 4.2.2 and use 4.6 toolchain. Could you have time to check this build break?
You can know how to build flatfish in https://wiki.mozilla.org/FirefoxOS/TCP/Patching and let me know if you need any help.
Thanks,
Flags: needinfo?(seth)
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(seth)
Resolution: --- → DUPLICATE
Duplicate of bug: 1057840
You need to log in before you can comment on or make changes to this bug.