bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

upload new version fails.

RESOLVED FIXED in 2014-09

Status

addons.mozilla.org Graveyard
Developer Pages
P1
critical
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

unspecified
2014-09
x86_64
Windows 7

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
When I new version uploaded.
AMO error that the version is already exist.
(Reporter)

Comment 1

4 years ago
STR
1. login AMO
2. Goto my addon 
3. Click "Manage Status & Versions"
4. Click [Upload a New Version]
5. Click [Select a file]
   -- no error
6. Click [Add Version]

Actual results:
    Version xxx already exists

Expected results:
upload should be performed successfully.
Blocks: 1058682
@Alice: thanks for your report, and sorry that you are issuing this.

A few points:

- if you have tried to upload more than one new version, are you seeing this error each time for very new version you try to upload? Or is it only occurring from time to time?

- I had no luck to reproduce the bug locally. Can you maybe try to reproduce it on dev: https://addons-dev.allizom.org/ ?

- can you give me the addon name/slug and the number of the version you are trying to upload?

Thanks! :)
Flags: needinfo?(alice0775)
I also see this problem for my jetpack addon, built with cfx against addon-SDK 1.17.

I see it even for the first upload after building with an incremented package.json version.

Is this supposed to work for valid semver version numbers like 0.3.4 ?

My addon is
https://addons.mozilla.org/en-US/firefox/addon/jot/versions/

This does not seem to be a hard failure, though.

After a while the uploaded version becomes available, sometimes after first showing 0 files for a while.

Is there human intervention on the AMO side recovering for these issues?

The "transactional feedback" of AMO feels very awkward at the moment.

I had cases where after I deleted a version (because Save Changes for compatibility and version information resulted in "The site could be temporarily unavailable or too busy. Try again in a few moments.") it first became available in the Developer Hub only to be shown deleted a few minutes later.

That's why I was suspecting that some people at AMO are manually correcting failed transactions.
@Adrian: thanks for those useful details! Can you give me the version number you are trying to upload?

Thanks :)
Flags: needinfo?(adrian)
(Reporter)

Comment 5

4 years ago
(In reply to Yohan Boniface [:ybon] from comment #2)
> @Alice: thanks for your report, and sorry that you are issuing this.
> 
> A few points:
> 
> - if you have tried to upload more than one new version, are you seeing this
> error each time for very new version you try to upload? Or is it only
> occurring from time to time?

5-6times, it seems to continuously happen.
> 
> - I had no luck to reproduce the bug locally. Can you maybe try to reproduce
> it on dev: https://addons-dev.allizom.org/ ?
> 

It seems OK.
However, I cannot upload maxVersion 32.* or 33.0a2.
=========================================
Your add-on failed validation with 1 error.

    Invalid maximum version number
=======================================

> - can you give me the addon name/slug and the number of the version you are
> trying to upload?
> 

https://addons.mozilla.org/en-US/developers/addon/default-fullzoom-level/edit

I tried version 7.1, 7.1.1, 7.1.2, 7.2, 7.2.1 as I remember. (I am not sure but finally 7.3 seems OK) These were changed only version number.
Flags: needinfo?(alice0775)
(In reply to Yohan Boniface [:ybon] from comment #4)
> @Adrian: thanks for those useful details! Can you give me the version number
> you are trying to upload?
> 
> Thanks :)

I last saw the problem today with 0.3.13.

I deleted it again as described above and uploaded it again. This is what is there right now, pending preliminary review.

I have already installed it locally from there and it works fine.

I have seen this for many version now, but I have proof for one in a snapshot I am attaching now.
Flags: needinfo?(adrian)
Created attachment 8479195 [details]
Screen Shot 2014-08-24 at 10.41.28.png
@Alice, here are the versions I can see in the db (starting at 7.0): 7.0.1, 7.0.3.1, 7.1.1, 7.1.2, 7.2, 7.3
Does that sounds legit?

@adrian: O.3.7 (from your screenshot) is in db (appears created on 2014-08-24 01:40:31), so the error message saying "Version 0.3.7 already exists" is "expected". This version is not expected to be in db?
(Reporter)

Comment 9

4 years ago
(In reply to Yohan Boniface [:ybon] from comment #8)
> @Alice, here are the versions I can see in the db (starting at 7.0): 7.0.1,
> 7.0.3.1, 7.1.1, 7.1.2, 7.2, 7.3
> Does that sounds legit?
> 

Aha, yes, it is correct.

> @adrian: O.3.7 (from your screenshot) is in db (appears created on
> 2014-08-24 01:40:31), so the error message saying "Version 0.3.7 already
> exists" is "expected". This version is not expected to be in db?
(In reply to Alice0775 White from comment #9)
> (In reply to Yohan Boniface [:ybon] from comment #8)
> > @Alice, here are the versions I can see in the db (starting at 7.0): 7.0.1,
> > 7.0.3.1, 7.1.1, 7.1.2, 7.2, 7.3
> > Does that sounds legit?
> > 
> 
> Aha, yes, it is correct.
> 
> > @adrian: O.3.7 (from your screenshot) is in db (appears created on
> > 2014-08-24 01:40:31), so the error message saying "Version 0.3.7 already
> > exists" is "expected". This version is not expected to be in db?

Yohan, is that red text "Version x.y.z already exists" that I get on the first ever upload of x.y.z expected?

It looks like an error to me, being red, and happening when that version could not have *already* existed before this upload.
Humm, adrian, I'm not sure to connect every bit of information we have.

When have you taken the attached screenshot?
So I uploaded brand new 0.3.14 by clicking link

Upload New Version
at
https://addons.mozilla.org/en-US/developers/addon/jot/versions#version-upload

I get a popup titled
Add a new Version

[v] All Mobile Platforms

[Select a file...]
C:\Users\AichnerAd\tmp\mozilla\JotFirefox\Jot\jot.xpi

[Add Version]

At this point, after a short wait, I get:

    Version 0.3.14 already exists

I click the Cancel link

----
I now see

Next version of this add-on 	Status 	Validation 	Delete
Version 0.3.14 August 26, 2014 	
Awaiting Preliminary Review (1 file)
	

    All Platforms
        0 errors, 3 warnings

Some other times I got (0 files) at first.

Please let me know if what I am doing looks right or whether I am deviating from the prescribed use model.

Thanks!
Created attachment 8479308 [details]
Screen Shot 2014-08-26 at 21.56.38.png

Version 0.3.14 already exists

Comment 14

4 years ago
Hi all,
I have same problem. After validation finished, AMO said new version is existing.
But It seems upload new version was finished in background. Because "Manage Status & Versions" shows new version and queued for review.
> Please let me know if what I am doing looks right or whether I am deviating from the 
> prescribed use model.

Seems you are doing everything right :)

And the infos you are giving are very useful, thanks!

Updated

4 years ago
Priority: -- → P1
Target Milestone: --- → 2014-09
Still not luck to reproduce locally, nor in dev or stage. :s

All of you having the bug, one thing you can do to help is trying to reproduce the bug in stage: https://addons.allizom.org/ 

It may be that we are failing to reproduce because we are not exactly following the same process as you, or we are missing some specific metadata, etc.

If you have the error "Invalid maximum version number", please change the <em:maxVersion> number in your install.rdf to match one in https://addons.allizom.org/en-US/firefox/pages/appversions/

Thanks in advance for your help!

Updated

4 years ago
Duplicate of this bug: 1056177
Interesting comment in a duplicate bug https://bugzilla.mozilla.org/show_bug.cgi?id=1056177#c3
(In reply to Yohan Boniface [:ybon] from comment #16)
> Still not luck to reproduce locally, nor in dev or stage. :s
> 
> All of you having the bug, one thing you can do to help is trying to
> reproduce the bug in stage: https://addons.allizom.org/ 

So, i cannot reproduce it for
https://addons.allizom.org/en-US/developers/addon/jot/versions
but that site is obviously not as busy as the production site.

I followed my use case described in comment 12.

> 
> It may be that we are failing to reproduce because we are not exactly
> following the same process as you, or we are missing some specific metadata,
> etc.
> 
> If you have the error "Invalid maximum version number", please change the
> <em:maxVersion> number in your install.rdf to match one in
> https://addons.allizom.org/en-US/firefox/pages/appversions/
> 
> Thanks in advance for your help!
Thanks for that, adrian!

One more question for you: do you *always* have the "Version xxx already exists" message, or sometimes you have no message, popup doesn't close, but after some time the version appears to be created as expected?
Flags: needinfo?(adrian)
(In reply to Yohan Boniface [:ybon] from comment #20)
> Thanks for that, adrian!
> 
> One more question for you: do you *always* have the "Version xxx already
> exists" message, or sometimes you have no message, popup doesn't close, but
> after some time the version appears to be created as expected?

I always get the message on the production site.

Just tried and got it for
Version 0.3.15 already exists
as well.

I still have the dialog open.

In a newly opened tab
https://addons.mozilla.org/en-US/developers/addon/jot/versions/1594514
I see
Next version of this add-on 	Status 	Validation 	Delete
Version 0.3.15 August 28, 2014 	
Awaiting Preliminary Review (1 file)
    All Platforms
        0 errors, 3 warnings

The popup never closes.

(The new version eventually shows up in preliminary review, sometimes first showing (0 files) in Status&Versions.)

See also bug 1059759, which may be related.

The AMO site seems especially sluggish right now, as of this comment.
Flags: needinfo?(adrian)
Adrian, we need you again :)

Are you able to provide a screencast of the upload process? If yes, what would help us a lot is if you open your javascript console (Ctrl-Shift-K), start the screencast, do the upload as you usually do with a brand new version, and stop the screencast when you have the error message.

Still no luck to reproduce the "Validation xxx already exists" on our side. There are asynchronous process around, and it's all about understanding why "suddenly" the form submission takes ages to finish. So such screencast could help us understand the succession of events in your case.

Thanks in advance!
Flags: needinfo?(adrian)
(In reply to Yohan Boniface [:ybon] from comment #22)
> Adrian, we need you again :)
> 
> Are you able to provide a screencast of the upload process? If yes, what
> would help us a lot is if you open your javascript console (Ctrl-Shift-K),
> start the screencast, do the upload as you usually do with a brand new
> version, and stop the screencast when you have the error message.
> 
> Still no luck to reproduce the "Validation xxx already exists" on our side.
> There are asynchronous process around, and it's all about understanding why
> "suddenly" the form submission takes ages to finish. So such screencast
> could help us understand the succession of events in your case.
> 
> Thanks in advance!

What log levels should i enable for Net CSS JS Security Logging?

How with you screencast this? Using a firefox add-on?
Flags: needinfo?(adrian)
> What log levels should i enable for Net CSS JS Security Logging?

Net and JS, thanks :)

> How with you screencast this? Using a firefox add-on?

I use byzanz for doing screencast (on Ubuntu), I know that QA guys are using http://screencast.com/ for that, but I've never used it myself.

If it's too much of a pain, don't bother skipping the request!

Comment 25

4 years ago
(In reply to Yohan Boniface [:ybon] from comment #18)
> Interesting comment in a duplicate bug
> https://bugzilla.mozilla.org/show_bug.cgi?id=1056177#c3

Just noticed this method currently works for uploading/updating add-ons, but they won't be distributed through auto update that way. (tested with a few builds on my add-ons beta/dev channel)
(In reply to Aris from comment #25)
> (In reply to Yohan Boniface [:ybon] from comment #18)
> > Interesting comment in a duplicate bug
> > https://bugzilla.mozilla.org/show_bug.cgi?id=1056177#c3
> 
> Just noticed this method currently works for uploading/updating add-ons, but
> they won't be distributed through auto update that way. (tested with a few
> builds on my add-ons beta/dev channel)

Are auto-updates supposed to work for preliminarily reviewed add-ons?

It must, because of this feedback:
https://addons.mozilla.org/en-US/firefox/addon/jot/reviews/620750/

A linux system with jot 0.3.9 has not automatically updated to 0.3.14.

It also does not update when I manually check in to Add-on Manager.

Browser Console shows VersionCheck.php running and not finding any updates.

Comment 27

4 years ago
If there is no fully reviewed version, a prelim. reviewed should auto update the previous one.
Beta/dev updates on dev channel should also be auto updated.
(In reply to Aris from comment #27)
> If there is no fully reviewed version, a prelim. reviewed should auto update
> the previous one.
> Beta/dev updates on dev channel should also be auto updated.

Thanks!

Good news: my linux system got the update today (times are +0200):

10:21:16.947 GET https://versioncheck-bg.addons.mozilla.org/update/VersionCheck.php [HTTP/1.1 200 OK 1023ms]
10:21:17.604 1409386877604	addons.update-checker	WARN	Update manifest for ubufox@ubuntu.com did not contain an updates property
10:21:18.615 1409386878615	addons.update-checker	WARN	Update manifest for {972ce4c6-7e08-4474-a285-3208198ce6fd} did not contain an updates property
10:21:21.225 GET https://addons.cdn.mozilla.net/user-media/addons/529638/jot-0.3.14-an+fx.xpi [HTTP/1.1 200 OK 1329ms]
10:21:21.226 GET https://versioncheck-bg.addons.mozilla.org/update/VersionCheck.php [HTTP/1.1 200 OK 1172ms]
(In reply to Yohan Boniface [:ybon] from comment #22)
> Adrian, we need you again :)
> 
> Are you able to provide a screencast of the upload process? If yes, what
> would help us a lot is if you open your javascript console (Ctrl-Shift-K),
> start the screencast, do the upload as you usually do with a brand new
> version, and stop the screencast when you have the error message.

The movie has been cancelled!

I was able to upload (ca. 20 seconds until popup goes away) and edit version information just fine yesterday and today.

> 
> Still no luck to reproduce the "Validation xxx already exists" on our side.
> There are asynchronous process around, and it's all about understanding why
> "suddenly" the form submission takes ages to finish. So such screencast
> could help us understand the succession of events in your case.
> 
> Thanks in advance!
> The movie has been cancelled!

> I was able to upload (ca. 20 seconds until popup goes away) and edit version 
> information just fine yesterday and today.

Cool!

It seem linked to an Op issue (see bug 1058682). We are waiting a bit before claiming it's totally fixed. So thanks for your confirm, that makes us closer to this point! :)

Comment 31

4 years ago
Upload work fine for a while now and it is also stable.

Thanks to all who were involved fixing this problem.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.