Add Searx as a search engine in Browser app.

RESOLVED DUPLICATE of bug 897445

Status

Firefox OS
Gaia::Search
--
enhancement
RESOLVED DUPLICATE of bug 897445
4 years ago
4 years ago

People

(Reporter: monsieurtino, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Android; Tablet; rv:34.0) Gecko/34.0 Firefox/34.0 (Nightly/Aurora)
Build ID: 20140826030203

Steps to reproduce:

[proposal][feature] Add Searx as a search engine in the list (like Google,Bing and Yahoo!).


Actual results:

Searx is not in the list.


Expected results:

Selection of Searx in the list.
(Reporter)

Updated

4 years ago
Severity: normal → enhancement

Comment 1

4 years ago
This requires a strong reason and discussion.
Please provide reasons.
Component: Gaia::Browser → Gaia::Search
Flags: needinfo?(monsieurtino)
(Reporter)

Comment 2

4 years ago
(In reply to YF (Yang) from comment #1)
> This requires a strong reason and discussion.
> Please provide reasons.

Well, Google, Bing and Yahoo! don't care about privacy. Adding Searx (like DuckDuckGo, see https://bugzilla.mozilla.org/show_bug.cgi?id=1040865) will permit to users to have privacy on search.
Flags: needinfo?(monsieurtino)
I think a better solution would be to add OpenSearch support so that users can add their own search engines.

Comment 4

4 years ago
(In reply to Ben Francis [:benfrancis] PTO until 10th September from comment #3)
> I think a better solution would be to add OpenSearch support so that users
> can add their own search engines.

Yes, by bug 897445.
Yup, as Ben and Yang have said let's solve this by adding open search support in bug 897445. Marking as a duplicate for now as that will solve this. Thanks for filing this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 897445
You need to log in before you can comment on or make changes to this bug.