Automatic updates broken for some add-ons

VERIFIED FIXED in 2014-09

Status

addons.mozilla.org Graveyard
Public Pages
P1
critical
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: Baris Derin, Assigned: magopian)

Tracking

unspecified
2014-09

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140716183446

Steps to reproduce:

Reader has been reviewed two days ago but automatic update does not download new version for Firefox users. 
https://addons.mozilla.org/en-US/firefox/addon/reader/

Update xml still belongs to an old version (v31.5) although the current version is v31.7.
updateLink in that file also does not work.

https://versioncheck.addons.mozilla.org/update/VersionCheck.php?reqVersion=2&id={20068ab2-1901-4140-9f3c-81207d4dacc4}&version=31.6&maxAppVersion=35.0&status=userEnabled&appID={ec8030f7-c20a-464f-9b0e-13a3a9e97384}&appVersion=31.0&appOS=Darwin&appABI=x86_64-gcc3&locale=en-US&currentAppVersion=31.0&updateType=97&compatMode=normal
Blocks: 1058682
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

3 years ago
This also appears to be happening for me on at least the 'NoScript' extension.

Please see following Mozine thread for more instances.

Firefox 31 Addons Not Updating • mozillaZine Forums
http://forums.mozillazine.org/viewtopic.php?p=13734323#p13734323

This is a severe bug.

Comment 2

3 years ago
Sorry, forgot UA isn't automatically included (and cannot edit own comments)

My reported instance is on

Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0 - Build ID: 20140716183446

I could not obtain notification of latest 'NoScript' and 'Classic Theme Restorer' updates and only discovered them when requesting to view a listing of most recently updated FF addons on AMO website.

Until recently I was able to successfully do 'Check for updates' from inside the addons manager panel in Firefox 31.0. This no longer shows eligible updates.

Updated

3 years ago
Severity: normal → critical
Priority: -- → P1
Target Milestone: --- → 2014-09

Comment 3

3 years ago
I can also confirm very similar issue.
See bug 1059853

DJ-Leith
(Assignee)

Comment 4

3 years ago
It seems some slave databases are out of sync, which could be causing the issue. Still investigating.
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1059853
(Assignee)

Comment 6

3 years ago
This should now be fixed, since the databases are back in sync.
Assignee: nobody → mathieu
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Verified by installing https://addons.mozilla.org/en-US/firefox/addon/reader/ v31.5 then searched for updates. v31.7 was found and installed.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

3 years ago
I can verify it's fixed. Thanks Mathieu for looking into this.
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.