Closed Bug 1058664 Opened 6 years ago Closed 6 years ago

APZ overflow test page click does not work

Categories

(Core :: Panning and Zooming, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla34

People

(Reporter: mchang, Assigned: kats)

References

Details

(Keywords: regression)

Attachments

(2 files, 2 obsolete files)

When trying to click the link on http://people.mozilla.org/~kgupta/tmp/overflow.html# on b2g while zoomed in, I have to touch the area above the link. This was working before. While this is a crafted case, it probably means something is wrong in APZ and APZ hit testing in general. 

Tested bad: 201504:dc352a7bf234
Tested good: Unknown for now :(

Testing revisions 13dae58b4a5e and de467cc6208f, which are one week and two weeks ago to see if they are good.
Good Gecko: 199504:de467cc6208f
Gaia: ea93363a8c424d65a9ad91438ce6961377a20f98

This is gecko regression.
Bisect Log:
200614:8d121ead4ff7 - bad
200036:b8e0173c9c47 bad, build bustage, move to 3998dcd6b147, bug 1049133 
200235:3998dcd6b147 - good
200449:a2a4617a6b4e - good
200477:43167be71864 - good
200496:8226ee398468 - bad
200420:04a531d5647e  - build bustage, move to 200423:025b1963a037, bug 1015518
200423:025b1963a037 - good
200485:7dc893ff9125 - bad
200481:715e09f33cd9 - good
200483:c4402de56732 - good
200484:073b4e162b5d - good

The first bad revision is:
changeset:   200485:7dc893ff9125
user:        Kartikaya Gupta <kgupta@mozilla.com>
date:        Tue Aug 19 21:17:09 2014 -0400
summary:     Bug 1052063 - Reverse the order of transforms applied for layers during composition. r=botond

Kats, do you think you can take a look at this please? Thanks!
Flags: needinfo?(bugmail.mozilla)
Assignee: mchang → bugmail.mozilla
Blocks: 1052063
Flags: needinfo?(bugmail.mozilla)
Summary: APZ Overflow Test Page Click Does Not Work → APZ overflow test page click does not work
Attached patch The patch (obsolete) — Splinter Review
This works, but I need to convince myself it's correct before I request review. Will ruminate on it over lunch.
Comment on attachment 8480643 [details] [diff] [review]
The patch

This is wrong. Been pulling my hair out fighting with these coordinate systems and I might have something correct but still thinking about it.
Attachment #8480643 - Attachment is obsolete: true
Attached patch Fix (obsolete) — Splinter Review
Attachment #8480858 - Flags: review?(botond)
Comment on attachment 8480858 [details] [diff] [review]
Fix

Review of attachment 8480858 [details] [diff] [review]:
-----------------------------------------------------------------

As mentioned on IRC, even in the absence of an actual CSS transform, I don't believe that Layer space with the CSS transform applied is equivalent of LayoutDevice space, because the CSS transform only cancels out the layer's own resolution, while LayoutDevice space is Layer space with the entire cumulative resolution unapplied.

I believe multiplying by the parent resolution as well would make this correct.
Attachment #8480858 - Flags: review?(botond) → review-
Attached patch Fix (v2)Splinter Review
Ah, I see what you mean now, and I think it makes sense. In the example I was testing the parent resolution was 1 so it didn't matter. Updated
Attachment #8480858 - Attachment is obsolete: true
Attachment #8480917 - Flags: review?(botond)
Attachment #8480917 - Flags: review?(botond) → review+
https://hg.mozilla.org/mozilla-central/rev/100b82ca2f3f
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla34
You need to log in before you can comment on or make changes to this bug.