If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Settings] 'No memory card' error is present when launching media apps and no media options when opening media storage in settings

RESOLVED DUPLICATE of bug 1058376

Status

Firefox OS
Gaia::Settings
RESOLVED DUPLICATE of bug 1058376
3 years ago
3 years ago

People

(Reporter: Josh Schmitt [Joshs], Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8479128 [details]
log.txt

Description:
Memory card is inserted while user opens media apps an error is displayed telling the user they have no memory card inserted.

Repro Steps:
1) Update a Flame to 20140826040204
2) Launch a media app e.g. Gallery, Video, and Music

Actual:
'No memory card' is displayed when user has a memory card inserted requiring a phone restart

Expected:
'No memory card' does not display if user has a SD card inserted.

Environmental Variables:
Device: Flame Master 319MB
Build ID: 20140826040204
Gaia: 4d1d0ea5a82cddeeab497774cfa1703639e3c7d9
Gecko: dc352a7bf234
Version: 34.0a1 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Notes:
Repro frequency: 6/10 60%
See attached: logcat
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Summary: [Settings] 'No memory card' error is present when launching media apps → [Settings] 'No memory card' error is present when launching media apps and no media options when opening media storage in settings
(Reporter)

Comment 1

3 years ago
Created attachment 8479129 [details]
Media.png
I saw this a number of times yesterday as well as today using:

Gaia   4d1d0ea5a82cddeeab497774cfa1703639e3c7d9
SourceStamp dc352a7bf234
BuildID 20140826040204
Version 34.0a1
Base Image: v123

In the most recent case, I attached my device to the USB port and added some content. When I tried to launch the gallery I got the same error.

Adding qawanted to get some good STR.
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Turns out this does not reproduce in KK base image (v165).  Perhaps a code change was made to work on KK base image broke on JB?
Confirmed that this does NOT reproduce in KK v2.0 and KK v2.1.  This bug is JB 2.0 and 2.1 specific, so it should not be a priority blocker.
(In reply to No-Jun Park [:njpark] from comment #4)
> Confirmed that this does NOT reproduce in KK v2.0 and KK v2.1.  This bug is
> JB 2.0 and 2.1 specific, so it should not be a priority blocker.

I don't think we should consider going down this path until we officially move mainline testing over to Kitkat. Otherwise, we'll lock us into situations without an ability to test certain functionality in mainline testing.

Comment 6

3 years ago
(In reply to Jason Smith [:jsmith] from comment #5)
> (In reply to No-Jun Park [:njpark] from comment #4)
> > Confirmed that this does NOT reproduce in KK v2.0 and KK v2.1.  This bug is
> > JB 2.0 and 2.1 specific, so it should not be a priority blocker.
> 
> I don't think we should consider going down this path until we officially
> move mainline testing over to Kitkat. Otherwise, we'll lock us into
> situations without an ability to test certain functionality in mainline
> testing.

Since JB 2.0 and 2.1 is not a shipping environment, this bug shouldn't be blocking.   We should continue to test on KK images as much as possible, but really need bug 1055305 to land so QA can switch over.  Until then, lets keep this bug open, and perhaps close this once we have official builds if its WFM.
(In reply to Tony Chung [:tchung] from comment #6)
> (In reply to Jason Smith [:jsmith] from comment #5)
> > (In reply to No-Jun Park [:njpark] from comment #4)
> > > Confirmed that this does NOT reproduce in KK v2.0 and KK v2.1.  This bug is
> > > JB 2.0 and 2.1 specific, so it should not be a priority blocker.
> > 
> > I don't think we should consider going down this path until we officially
> > move mainline testing over to Kitkat. Otherwise, we'll lock us into
> > situations without an ability to test certain functionality in mainline
> > testing.
> 
> Since JB 2.0 and 2.1 is not a shipping environment, this bug shouldn't be
> blocking.   We should continue to test on KK images as much as possible, but
> really need bug 1055305 to land so QA can switch over.  Until then, lets
> keep this bug open, and perhaps close this once we have official builds if
> its WFM.

I don't think that's the right direction to pursue. We cannot place ourselves into a situation where we can't test functionality because a production testing environment is not ready. Placing ourselves into a situation where we're waiting endlessly for an environment is ready means we're going to get ourselves blocked, which gets us no where. JB is currently our reference testing environment for 2.1 right now, which makes this a production environment that does need to be supported for 2.1. If kitkat becomes available as an environment that we can rely on, then we can re-evaluate. But sticking ourselves into inbetween state is going to do nothing but cause us to get testing blocked in multiple areas.
QA Contact: ckreinbring
I was able to repro the bug 5 out of 5 times each using 319 MB and 512 MB with the following steps:

1) Flash to build 20140826040204
2) Launch the Camera app.
3) Take a picture, then tap the Home button when the shutter sound plays.
4) Launch the Gallery app, then tap the Home button as the pictures load.
5) Launch the Video app and observe the screen that is shown.
6) Tap the Home button and launch Settings.
7) Select Media Storage in the Storage section and observe the page that appears. (319MB ends here)
8) Long tap the Home button and close Settings.
9) Launch the Music app and observe the screen that is shown.
10) Tap the Home button and launch Settings again.
11) Select Media Storage in the Storage section and observe the page that appears.

Actual result: 
When launching the Video (319 MB) or the Music (512 MB) app, the "No memory card found" error page appears and does not get replaced by a list of videos or songs.
Going to the Media Storage settings sill show a page with no information on the internal storage or the SD card.
The user is also unable to flash the device if the bug repros and the user does not restart the phone.


BuildID: 20140826040204
Gaia: 4d1d0ea5a82cddeeab497774cfa1703639e3c7d9
Gecko: dc352a7bf234
Platform Version: 34.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
setting 2.0 affected based on comment 4
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
status-b2g-v2.0: --- → affected
Flags: needinfo?(jmitchell)
(In reply to Joshua Mitchell [:Joshua_M] from comment #9)
> setting 2.0 affected based on comment 4

comment 4 doesn't conclude this reproduces on 2.0. comment 4 is just stating an opinion of priorities of 2.0 & 2.1 on JB vs. kitkat. Flagging qawanted to check if this happens on 2.0.
QA Whiteboard: [QAnalyst-Triage+]
status-b2g-v2.0: affected → ---
Keywords: qawanted
Dupe of bug 1058376 ?
Keywords: qawanted
Looks like it.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1058376
You need to log in before you can comment on or make changes to this bug.