[e10s] Paste context menu is missing on <textarea>

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: alice0775, Assigned: mconley)

Tracking

Trunk
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+)

Details

(URL)

(Reporter)

Description

4 years ago
Steps To Reproduce:
1. Open https://dev.mozilla.jp/2014/08/firefox-32-addon-compatibility/
2. Scroll to the bottom
3. Copy any text
4. Attempt to paste clipboard text using context menu into <textaea>
   ---- no paste command
(Reporter)

Comment 1

4 years ago
sometimes, Copy command is also missing.
(Reporter)

Updated

4 years ago
Summary: [e10s] Paste context menu is missing on <textaea> → [e10s] Paste context menu is missing on <textarea>
(Reporter)

Updated

4 years ago
See Also: → bug 1058774
(Assignee)

Updated

4 years ago
Assignee: nobody → mconley
tracking-e10s: ? → +
(Assignee)

Updated

4 years ago
Blocks: 1060070
Sounds like bug 1060529
Depends on: 1060529
(Assignee)

Comment 3

4 years ago
(In reply to Dave Townsend [:mossop] from comment #2)
> Sounds like bug 1060529

Yep, duping.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1060529

Comment 4

4 years ago
Not sure why this was marked a duplicate.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 5

4 years ago
After some testing, I think there is a general bug with the spellchecker menuitems not initializing properly and failing with a Permission denied to access property 'value' error. This causes any commands handled later to fail. Paste is one such item. Disabling the call to initSpellingItems makes pasting work again.

I filed bug 1071771 on this.
Depends on: 1071771

Updated

4 years ago
Duplicate of this bug: 1058774

Comment 7

4 years ago
Alice, can you retest this bug now that the patch for bug 1071771 has been made?

Updated

4 years ago
Flags: needinfo?(alice0775)
(Reporter)

Comment 8

4 years ago
I cannot reproduce any more
https://hg.mozilla.org/mozilla-central/rev/14665b1de5ee
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0 ID:20141001030205
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Flags: needinfo?(alice0775)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.