Don't send review emails to users without review permission

RESOLVED FIXED

Status

support.mozilla.org
General
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: scootergrisen, Assigned: rehan)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: p=1 u=contributors)

(Reporter)

Description

4 years ago
edwin-after-1208255edwin-sumo
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140716183446

Steps to reproduce:

Go to https://support.mozilla.org/en-US/users/settings and select all the options i guess.


Actual results:

When other localizers make an review i recieve an e-mails about it with a link to the review, but when i visit the link i get this page:
'
Access denied
You do not have permission to access this page.
'


Expected results:

If i dont have permission to view the review i guess there is not need for me to recieve e-mails about it.

Comment 2

4 years ago
Hi scootergrisen,

What message do you get on the target page when you click the link? Can you paste it here? Thanks!
(Reporter)

Comment 3

4 years ago
'
Access denied

You do not have permission to access this page.
'
Weird.. I wonder what permission you are missing.

Comment 5

4 years ago
This may be caused by scootergrisen not having Reviewer permissions.

Can we strip the outgoing emails from review links for users who don't have such permissions?
Flags: needinfo?(feer56)
(Reporter)

Comment 6

4 years ago
True i dont have reviwer permission at the moment : https://support.mozilla.org/da/kb/locales/da
Somebody from SUMODEV would need to comment. Maybe rdalal?
Flags: needinfo?(feer56)

Updated

3 years ago
Summary: Reciving E-mails with links that i does have access to read → Remove review links from emails outgoing to users who don't have reviewer permissions
Michal, should we even send these emails to people who are not reviewers?
Flags: needinfo?(mdziewonski)

Comment 9

3 years ago
Kadir: Ideally, the Reviewers would get one email (along the lines of "Article X is ready for your review"), and the submitters would get another (along the lines of "Your contribution is undergoing review. Thank you!")

If it's easier to switch notification emails off for non-reviewers, let's go for that, and explore the "ideal" scenario later.
Flags: needinfo?(mdziewonski)
Mike, can you give us an estimate for both cases?
Whiteboard: p=? u=contributors
Looking through the code that sends these notifications, I think it would be 1 point to remove the notification for people without the review permission, and another point to add the second email.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 12

3 years ago
Thanks, Mike.

Let's go for the first option, then? The latter (since it's possible) can wait a bit.
Ok. I've updated this bug to reflect that.

Vesper, can you file another bug for the new email, so we can track it separately?
Summary: Remove review links from emails outgoing to users who don't have reviewer permissions → Don't send review emails to users without review permission
Whiteboard: p=? u=contributors → p=1 u=contributors

Comment 14

3 years ago
Filed and prioritized in the backlog as https://bugzilla.mozilla.org/show_bug.cgi?id=1215087
(Assignee)

Updated

3 years ago
Assignee: nobody → rdalal
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.