[e10s] The Pocket "read later" button in Location Bar is not working when e10s is enabled (won't let me add to my reading list)

VERIFIED FIXED

Status

()

Firefox
Extension Compatibility
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

({addon-compat})

Trunk
x86_64
Linux
addon-compat
Points:
---

Firefox Tracking Flags

(e10s+)

Details

(URL)

STR:

SETUP STEPS: Get Pocket installed, and make your profile e10s
=============================================================
 0. Create a (free) account at https://getpocket.com/

 1. Install Pocket extension from
   https://addons.mozilla.org/en-US/firefox/addon/read-it-later/

 2. Enable e10s by setting browser.tabs.remote.autostart to true, and restart Firefox.

 3. Click the pocket icon, at the right end of your location bar.
    --> A dialog pops up to create account / log in.
 4. Log into your account.

TRIGGERING THE BUG
==================
 5. Now, visit any site with some text that would be suitable for saving to Pocket -- e.g. https://ftp.mozilla.org/pub/mozilla.org/README

 6. Click the pocket icon at the right end of your location bar.

EXPECTED RESULTS:
The icon should change color, and the page should end up in my reading list.

ACTUAL RESULTS:
Nothing happens. (Icon doesn't change color, and my reading list is unchanged.)

I'm using Nightly 34.0a1 (2014-08-26)
Mozilla/5.0 (X11; Linux x86_64; rv:34.0) Gecko/20100101 Firefox/34.0
with Pocket 3.0.5, released June 25, 2014
Interestingly, if I visit a page that is *already* in my reading list, then the icon changes color (as it should) to indicate this, and I can click the icon to *archive* the page (indicating that I've read it).

So, the only thing that doesn't work is clicking the icon to *add* to my reading list (which is unfortunately the main function of the add-on).
Summary: [e10s] The Pocket "read later" button in Location Bar is not working in e10s → [e10s] The Pocket "read later" button in Location Bar is not working when e10s is enabled (won't let me add to my reading list)
Also: I believe Pocket may no longer be supporting this extension. They recommend users use a new Add-on that plugs into the Social API at https://getpocket.com/firefox/

I'm still using the old one, though, because I prefer it. (it's a bit faster & more useful)
Comment hidden (obsolete)
(Note that the "new" social-API-based Pocket add-on is also (separately) broken in e10s simply because Social API is currently broken in e10s, as shown by the various Social API dependencies off of bug 905436. So, neither of the Pocket add-ons work with e10s.)
tracking-e10s: --- → +
Keywords: addon-compat
(NOTE: Currently, this add-on is completely broken in nightlies (ever since yesterday I think), with or without e10s, due to the JS engine getting stricter about variable-redeclaration. That's tracked in bug 1068790.)
See Also: → bug 1068790
The developer has been contacted through AMO.
The add-on is working correctly now on Nightly. I assume this is because of new shims, since the only fixes done for the add-on are the ones brought up in comment #5.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Confirmed fixed.

(Perhaps this should be WORKSFORME, since we don't strictly know when it became fixed or what change fixed it? Though maybe it's not a big deal.)
(I tested with latest nightly, 39.0a1 (2015-03-23), when verifying that it's fixed, BTW)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.