[Browser] No lock in the URL bar shown when visiting a secure website

RESOLVED INVALID

Status

RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: KTucker, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 affected)

Details

(Whiteboard: [2.1-flame-test-run-1])

Attachments

(2 attachments)

Created attachment 8479309 [details]
No lock Secure Site.png

Description:
When the user visits a secure webpage such as http://www.verisign.com, no lock icon is shown in the URL bar. 

Repro Steps:
1)  Updated Flame to Build ID: 20140826040204
2)  Open "Browser2" and go to the webpage http://verisign.com
3)  Notice the URL bar.

Actual:
No lock is shown to indicate to the user that they are on a secure website.

Expected:
A lock is shown on the URL bar to let the user know they are on a secure webpage.

Environmental Variables
Device: Flame(319mb) 2.1
Build ID: 20140826040204
Gecko: https://hg.mozilla.org/mozilla-central/rev/dc352a7bf234
Gaia: 4d1d0ea5a82cddeeab497774cfa1703639e3c7d9
Platform Version: 34.0a1
Firmware Version: v123

Notes:
Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/1648/
See attached: screenshot, logcat
Created attachment 8479310 [details]
Nolocklogcat.txt
This issue also occurs on the Flame 2.1(512mb) and Open C 2.1 devices when using Browser2. 

No lock is shown in the URL bar to indicate to the user that they are on a secure website. 

Flame 2.1

Environmental Variables:
Device: Flame Master (512mb)
BuildID: 20140825040204
Gaia: e424c85eda87a40c0fa64d6a779c3fa368bf770b
Gecko: daa84204a11a
Version: 34.0a1 (2.1 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Open C 2.1

Environmental Variables:
Device: Open_C Master
Build ID: 20140825040204
Gaia: e424c85eda87a40c0fa64d6a779c3fa368bf770b
Gecko: daa84204a11a
Version: 34.0a1 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

-------------------------------------------------------------------------------------------------

This issue does not occur using the original browser on the Flame 2.1(319mb), Open C 2.1, Flame 2.0(319mb), Open C 2.0, Flame 1.4(319mb) and Open C 1.4.

The lock is shown in the URL bar to indicate to the user that they are on a secure website.

Flame 2.1

Environmental Variables:
Device: Flame Master (319mb)
BuildID: 20140825040204
Gaia: e424c85eda87a40c0fa64d6a779c3fa368bf770b
Gecko: daa84204a11a
Version: 34.0a1 (Master) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Open C 2.1

Environmental Variables:
Device: Open_C Master
Build ID: 20140825040204
Gaia: e424c85eda87a40c0fa64d6a779c3fa368bf770b
Gecko: daa84204a11a
Version: 34.0a1 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Flame 2.0

Environmental Variables:
Device: Flame 2.0 (319mb)
BuildID: 20140825000201
Gaia: 4c8b5ced1966079086d86dec3098ecf340881306
Gecko: b0545e46d08b
Version: 32.0 (2.0) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Open C 2.0

Environmental Variables:
Device: Open_C 2.0
Build ID: 20140825000201
Gaia: 4c8b5ced1966079086d86dec3098ecf340881306
Gecko: b0545e46d08b
Version: 32.0 (2.0)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Flame 1.4

Environmental Variables:
Device: Flame 1.4 (319mb)
BuildID: 20140825063013
Gaia: cf9d74da6653efeb43d9653e81c61aa00e693a67
Gecko: cdcb73d0febc
Version: 30.0 (1.4)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0"

Open C 1.4

Environmental Variables:
Device: Open_C 1.4
BuildID: 20140825063013
Gaia: cf9d74da6653efeb43d9653e81c61aa00e693a67
Gecko: cdcb73d0febc
Version: 30.0 (1.4)
Firmware: P821A10v1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Closing this as invalid. I didn't put the s in http://. The lock shows up as expected with the correct web address.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
You need to log in before you can comment on or make changes to this bug.